14

This question already has an answer here:

When I'm just chilling on the desktop or doing whatever, Ubuntu 14.04 LTS will (every 10-20 minutes or so) just randomly freeze. The screen just stops, I can't see my mouse move, etc. However, I can Alt+Ctrl+F1 into a tty terminal (though it's not much use).

However, I noticed that if I close my laptop's lid, re-open it, then enter my password to unlock the lock screen, everything is fine.

What is going on here? How can I fix / stop / prevent this?

Note: My laptop has an nvidia-optimus setup, but Ubuntu 14.04 LTS automatically recognized it and had the nvidia drivers applied.

marked as duplicate by karel, user.dz, Kevin Bowen, Rinzwind, Avinash Raj May 12 '14 at 13:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Do you see any errors or warnings in /var/log/kern.log? – bain May 11 '14 at 22:56
  • 1
    This is not a duplicate question - you should check the other post! – Nicu Zecheru Jul 28 '14 at 11:00
10

This may be the cause of your problems: Nvidia-Prime Freeze

Theese two things have worked for me so far; either:

  1. Disable touchpad in: System settings -> Mouse & Touchpad -> "off" and use a regular USB mouse.

  2. Install nvidia-prime sudo apt-get install nvidia-prime, find "Nvidia Settings" in dash, and under "Prime Profiles" choose "Intel(Power saving mode)"

The latter disables your dedicated graphics card, but works well for all the day-to-day tasks. Also, this made my computer a lot quieter (and surely less power consuming) which is comfortable when you are just browsing the web anyway...

Hope this helps :)

  • I had the same problem, then I changed my driver. It's running fine for 2 days now. Here is the driver I am using now: dl.dropboxusercontent.com/u/4950646/… – Nicu Zecheru Jul 28 '14 at 11:01
  • How do you 'find' Nvidia Settings in dash? I type 'dash' and get into another command-line interpreter. – カオナシ Jul 29 '14 at 7:22
  • By tapping the windows button (dash?), and then simply start typing "nvidia" a green icon named "NVIDIA X Server Settings" should become visible. – Hme Aug 19 '14 at 20:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.