Recently I installed Ubuntu 14.04, and I would like to install RabbitVCS on my system. Does RabbitVCS work on the new Ubuntu? Has someone already tried it out?

  • My own policy @Lucio, is to remove signatures only when there are other edits to be made at the same time. Certainly it seems silly to remove signatures while ignoring other issues in the post. It seems even sillier to remove a signature with the edit comment "fixed typos". – TRiG May 12 '14 at 22:45
up vote 30 down vote accepted

I personally haven't tried it, but there is a version for trusty (14.04) in the PPA, so I guess it should work.

You can always try if it's working (this will install RabbitVCS for CLI (terminal), gedit and Nautilus 3, if you're using another file manager see the full list of packages here):

sudo add-apt-repository ppa:rabbitvcs/ppa
sudo apt-get update
sudo apt-get install rabbitvcs-cli rabbitvcs-core rabbitvcs-gedit rabbitvcs-nautilus3

As @GermanK notes in a comment, you must to restart nautilus for the change to take effect.

And if it doesn't you can remove it:

sudo apt-get remove rabbitvcs-cli rabbitvcs-core rabbitvcs-gedit rabbitvcs-nautilus3
  • This does not help. I try to translate the full error message: "The package rabbitvcs is not available, but is referenced of a other package. This could mean, that the package is missing, that it was replaced or is only avialable from another source." – user280604 May 11 '14 at 21:44
  • Try sudo apt-get install rabbitvcs-cli rabbitvcs-core rabbitvcs-gedit rabbitvcs-nautilus3. All installable packages are listed here (click on the arrow to show the packages). – Louis Matthijssen May 11 '14 at 21:49
  • Thx! It seems to work. I will test i later on this day. – user280604 May 11 '14 at 22:00
  • 4
    I had to restart nautilus to see it working: nautilus -q. Also I did chown -R $USER:$USER ~/.config/rabbitvcs taken from aruizca.com/…, although I don't know if that was required or not. – GermanK Sep 20 '14 at 15:56
  • The client kept opening and closing when I attempted to hit the remote repo. I went to the repo browser, typed in the repo and hit the magnifying glass icon and it prompted me to log in, then started working. – Cory Danielson Nov 19 '14 at 3:40

After following the installation steps to install RabbitVCS from the PPA:

$ sudo add-apt-repository ppa:rabbitvcs/ppa
$ sudo apt-get update
$ sudo apt-get install rabbitvcs-nautilus3

# Optional
$ sudo apt-get install rabbitvcs-gedit
$ sudo apt-get install rabbitvcs-cli

I had to do the following, as RabbitVCS menu entries were not showing up in the Nautilus:

$ sudo chown -R $USER:$USER ~/.config/rabbitvcs

Courtesy: http://aruizca.com/how-to-integrate-rabbitvcs-with-nautilus-file-manager-in-ubuntu-14-04-trusty-tahr/

After running the above command, the menu entries are visible.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.