2

I'm just trying to install Corebird. It has some dependencies and one of them is Gtk+ >= 3.12. I would say I have search a lot and finally frustrated from a lot of other dependencies. I'm afraid if Corebird worth it finally or not!

Is there a straight-forward way to install GTK+ 3.12 on my Ubuntu PC? I mean step-by-step tutorial!

  • There are similar question here – girardengo May 11 '14 at 18:37
  • The same problems exists in this solution. It just is repeating all other solutions. Compiling gtk+ needs some other packages which I can't find them. – Omid May 11 '14 at 18:51
  • Question header is about gtk, solution is about corebird. Can we fix that? – Tanasis Mar 26 '18 at 11:02
7

This question has already been answered here. Corebird packages are now available.

If you're on Ubuntu 14.04, open terminal and type:

sudo add-apt-repository ppa:gnome3-team/gnome3

sudo add-apt-repository ppa:gnome3-team/gnome3-staging

Then, for both 14.04 and 14.10 flavours, type:

sudo add-apt-repository ppa:ubuntuhandbook1/corebird

sudo apt-get update

sudo apt-get install corebird

Finally, remove gnome 3 staging ppa:

sudo add-apt-repository -r ppa:gnome3-team/gnome3-staging

source: http://ubuntuhandbook.org/index.php/2014/07/install-corebird-ubuntu-ppa/

  • well done! it works. just why should I remove gnome 3 staging ppa? – Omid Jul 26 '14 at 15:28
  • @Omid If you don't remove gnome3-staging your Software Updater might give you a "partial update" error, which would be hazardous. It is strongly advised not to keep that ppa. – jimpinho Aug 12 '14 at 14:58
  • Hrm, when installing last step, corebird, I received "The following packages have unmet dependencies: corebird : Depends: libgtk-3-0 (>= 3.11.2) but 3.10.8-0ubuntu1.6 is to be installed E: Unable to correct problems, you have held broken packages." – Elijah Lynn Jun 14 '18 at 23:40
  • Hrm, seems as if I confused libgtk for gtk+. At any rate, the source link has a comment with the same issue and one suggestion to sudo apt-get install libgtk-3-0 doesn't work as it is still an older version, and "up to date". – Elijah Lynn Jun 14 '18 at 23:44
  • Actually, I didn't add the gnome3-staging repo. I copied both lines in the beginning but had an error so just tried the first line and forgot to re-run with staging. corebird installed correctly, without having to install libgtk-3-0 since it figured out the dependency correctly. – Elijah Lynn Jun 14 '18 at 23:49
-2

You can download libgtk3-0-3.12 .deb file ftom Launchpad.net.

Then install that file with the command :

sudo dpkg -i {.DEB FILE NAME HERE]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.