1

I am experiencing many issues with my fresh installation of Ubuntu 14.04:

  • I can't open Google Chrome from the sidebar.
  • I can't search any applications in the dash.
  • f.lux and Screencloud have stopped running on startup.

As far as I can recall I began experiencing these issues after setting up the Google App Engine SDK for PHP, but it's possible this is being caused by something else entirely.

Running google-chrome in the terminal returns:

[6119:6119:0511/161156:ERROR:process_singleton_linux.cc(903)] Failed to create socket directory.
[6119:6119:0511/161156:ERROR:chrome_browser_main.cc(1198)] Failed to create a ProcessSingleton for your profile directory. This means that running multiple instances would start multiple browser processes rather than opening a new window in the existing process. Aborting now to avoid profile corruption.

Screencloud displays an alert box on startup saying

ScreenCloud is already running. Please close the running instance before starting a new one.

Lastly, there is an error icon in the system tray which has displayed a few different error messages:

I have researched each of these issues individually, tried every solution I could find, rebooted a hundred times, but nothing has changed. What can I do?

  • please add more info: did this happen after an upgrade to 14.04? Or did you do a clean install? When did this issue start? – JoKeR May 11 '14 at 15:38
  • @JohnnyD. Thanks for the feedback, I've edited the post. This is a clean install of 14.04. This started after I set up the Google App Engine SDK for PHP. – fabiomaia May 11 '14 at 15:47
  • @JohnnyD. I have run those commands before multiple times. I tried it again and it updated some packages as expected. In particular, it updated wine-compholio-i386, which is the package mentioned in the screenshot. I have rebooted, and now I'm getting a different error message in the system tray: imgur.com/LtKoqAy – fabiomaia May 11 '14 at 15:55
  • @JohnnyD. It did not tell me about broken packages or unmet dependencies. I ran the update commands again and it didn't tell me that either. – fabiomaia May 11 '14 at 16:25
  • @JohnnyD. However, when I ran sudo chmod 1777 /tmp followed by sudo google-chrome it gave me a different error about startup applications (I didn't make note of it). After sudo reboot everything started working again. All the issues I mentioned are fixed. Thank you! – fabiomaia May 11 '14 at 16:26
1

To solve this problem needs to give sudo permissions to /tmp it is where those/certain programs/apps write their temporary stuff to. For this run in Terminal:

sudo chmod 1777 /tmp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.