16

After a couple days of searching for solutions, I still cannot get a proper RDP connection fron Windows 7 to Ubuntu Desktop 13.10 (or 14.04). When I use RDP in Windows, it will connect to my Ubuntu box just fine, but I get a gray/black pixel screen with an "X" for a cursor.

Here's what I've tried so far (in both 13.10 and 14.04)

  • Created .xsession file to use gnome-2d

  • Installed xfce4 and updated .xsession file to use that

  • I did indeed restart xrdp after any change to the .xsession file

  • Modified startwm.sh to point to the location of the .xsession file

  • chmod 755 .xsession file so it's executable

  • Updated nvidia drivers

I'm at a loss as to what's going on. I was able to use x11vnc to take control of the Ubuntu machine, but I'm trying to create an actual remote session from Windows, and not just take control.

Any help would be greatly appreciated, I've been searching around for a solution, and so far any other people who've encountered this, their solution has not been successful for me.

7

OK so taking a quick break and finding a slightly different set of instructions allowed me to get this working! (FYI I did a clean install of 14.04 first)

Here's the link to the step-by-step instructions: http://c-nergy.be/blog/?p=5305

The two differences in these instructions were:

  1. Before installing xfce4, running an update
  2. The .xsession file was simply xfce4-session

I still can't get gnome-2d to work, but for the time being, I'm just happy I can create a remote session to my linux machine without actually taking control of it!

0
6

Here is what worked for Ubuntu 16.04 LTS (July 2017)

Step by Step:

cd
sudo apt-get update
sudo apt-get install xrdp
sudo apt-get update
sudo apt-get install xfce4
echo xfce4-session > .xsession

Now give it a try from a Windows machine (Windows Remote Desktop) and you will get the xfce4 desktop on the Ubuntu system. It looks different than the console but is fully functional.


This information came from

http://c-nergy.be/blog/?p=5305


Now, to go a little further, in order to be able to reconnect to the same session, do this:

cd /etc/xrdp
sudo vi xrdp.ini

find the line at the end of the [xrdp1] section that looks like this:

port=-1

and change it to say

port=ask5910

save it.

(If you don't do vi then you can use a text editor of your choice)

Now, when you try to login from another machine you will get three prompts. Username, password, and port. Port will be prefilled with 5910. If this is your first session you change the 5910 to -1 after entering username and password.

Then if you disconnect and want to reconnect, just leave it as 5910 and it will reconnect to the same session.

2

Install xrdp and xfce4 and make xrdp use xfce4:

sudo apt-get update    
sudo apt-get install xrdp    
sudo apt-get update    
sudo apt-get install xfce4

Point xrdp to use xfce4:

echo xfce4-session > ~/.xsession

Don't forget to Restart your xrdp service:

sudo service xrdp restart

Check your configured hostname for xrdp:

hostname -I
0
1

I was going crazy with this, as like many others (I suspect) I am trying to get a Linux VM set up for the upcoming MOOC. I landed here after trying the steps outlined on Griffons IT post unsuccessfully.

Long story short I remembered seeing somewhere about alt + f2. I had tried it and it did nothing.

This time I hit it before clicking on the annoying grey screen and Haaazah!!!! “Welcome to the first start of the panel”

I don’t know if it was just because I was holding my mouth correctly or if it was because it did the alt + f2 before clicking with the mouse but I’m in.

Hope this helps someone, it sure seems like there are a lot of people with this problem with no resolution.

1

Created a new user. With that new user I was able to logon with rdp. So it looks like there is a problem with the user profile (home dir).

Did copy the working home dir. Changed ownership and swapped it with the problematic one. And now problem is solved.

0

I have found an alternative solution:

apt-get install x2goserver

This will install x2go, which is opensource remote desktop (RDP) server for Linux with x2goclient available both for Linux and Windows.

Not the answer you're looking for? Browse other questions tagged or ask your own question.