0

I'm using Ubuntu 14.04 with TP-Link MA260 USB mobile broadband modem.

So far, modem worked 'out of the box' (plug-in, enter sim card pin number and select 'connect'). The problem is connection speed. Usually the speed is between 5 - 20 kB/s.

What's interesting: When I take the sim card out of the modem and put it into my mobile phone (Nokia E5), connect it via USB cable to computer and use the same procedure to connect, the speed is between 100 - 300 kB/s.

I also tried changing connection type in 'network connections' to 3G(UMTS/HSDPA), but it had no effect...

It seems to me that USB modem won't change from 2G to 3G.

Thanks for any help.

  • Do you see any errors or warnings in /var/log/kern.log? – bain May 11 '14 at 14:53
  • No, just a lot of logs about detecting new hardware... nothing like warning or error. – M.R.Tinch May 11 '14 at 15:26
0

UPDATE:

Did some research. The modem is working on frequency that is not supported for 3G in my country. I bought modem directly from my mobile provider and now it is working like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.