I recently installed the opensource game 0AD. Everything went fine, but when I run it I get the error

"You are using 260.19.* series NVIDIA drivers, which may crash the game. Please upgrade to 260.19.21 or later."

How do I go about updating this driver? I downloaded the 260.19.21 driver here. Its a .bin file.

3 Answers 3


Newer NVIDIA drivers are available in the X Updates PPA:

You want to add ppa:ubuntu-x-swat/x-updates to your software sources to upgrade them, you can follow these instructions here:

  • +1 I preffer this way, because with this ppa you will get the latest drivers when they come out. :)
    – kv1dr
    Jun 1, 2011 at 19:23
  • Hmmm. I added this and went to the repository but I couldn't find the NVIDIA driver I was looking for. Nothing for the NVIDIA driver I mentioned above.
    – kalaracey
    Jun 3, 2011 at 14:12
  • 270.41.19 is in there, can you edit your question and tag it with the version of ubuntu you're using? Jun 3, 2011 at 14:40

If you want to install the binary that comes directly from Nvidia, I can tell you how I have accomplished this in the past.

  1. Switch to TTY CTRL-ALT-F1

  2. Find the PID for gdm-binary (e.g., ps ax | grep 'gdm-binary')

  3. Kill associated PID for gdm-binary (e.g., sudo kill -9 1136)

With X shutdown, you are ready to install the binary from Nvidia. Please use the appropriate name for the binary you are attempting to install. The following example is using the NVIDIA-Linux-x86_64-270.41.19.run binary downloaded from Nvidia:

`sudo sh ./NVIDIA-Linux-x86_64-270.41.19.run`

Now it is a matter of following the prompts presented when running the binary. Generally speaking, I do not allow the binary to monkey with my xorg.conf. Once the Nvidia driver has been installed, I tend to like to shutdown the system rather than to reboot.

halt or shutdown now

Upon booting the system, if all has to gone to plan, the new Nvidia driver should functional. Hope this helps.

  • 1
    No need to kill gdm, sudo stop gdm will just stop the service. Jun 1, 2011 at 23:13
  • I tried this attempt because the above answer didn't have an option for the driver in question (260.19.21+). Unfortunately, it didn't turn out very well and I ended up having to sh ./NVIDIA... --uninstall and uninstall the driver and revert back. Thanks tho. I doubt it was your instructions that caused problems.
    – kalaracey
    Jun 3, 2011 at 15:01

This tells you how to install a bin file:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .