1

In the 2 years or so I have used Kubuntu 12.04, Dolphin has been my default file manager and Gwenview my default image viewer. Gwenview can also double up as a file manager, which can be useful when organising images and videos, but it provides less details (such as dates) on the files.

I have a number of icons on my desktop representing files or folders, and if I click on a folder it opened in Dolphin. A few days ago, it suddenly started opening Gwenview to see the folders - whether I inadvertently changed a setting, or this was done by a system update, I know not.

I've followed the advice in how-to-set-up-dolphin-as-default-file-manager, but it doesn't help; so I've uninstalled Gwenview. Ideally, I'd like Gwenview back as an image viewer, but Dolphin as default file manager. Is this possible, please?

4

Well, the regular method to change your default applications is to go into

System Settings > Default Applications

and click on File Manager. You should see Dolphin as an option.

Click Apply when done.

I don't know whether this is the method you used, but let us know how you get on. I also see Gwenview as an option to be a file manager, which seems a little odd.

4
  • Thanks, I had looked at File Associations and one or two other options in System Settings but these did not help.
    – WGCman
    May 11 '14 at 14:34
  • Many thanks,@Drac Noc. I had looked at File Associations and one or two other options in System Settings but these did not help. I had also tried uninstalling Gwenview but it reasserted itself as default on re-installation. This time, after re-installation, I went to Default Apps, changed the default from Dolphin to Gwenview and back again, and it seems to have got the message.
    – WGCman
    May 11 '14 at 14:42
  • Oh, well done! Good to see you got things working again.
    – Drac Noc
    May 11 '14 at 14:43
  • For others - when I first opened the File Manager section of the Default Applications, it seemed that Dolphin was the selected default. However, my system was still using GwenView from Sublime and Firefox. I had to first change the default option away from Dolphin and apply the change, before reasserting Dolphin as the default and applying it one more time.
    – HorusKol
    Sep 22 '17 at 3:28
0

Another possibility is to install exo-utils and it should provide exo-preferred-applications.

Run that in a terminal and under the Utilities tab, you should find the File Manager section. Specify Dolphin in that and see what happens.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.