I have an Ubuntu server on Amazon EC2, that I use for development, and today I stupidly cleared everything out of my ~/.ssh/authorized_keys file. Luckily I have an SSH open, so I am still connected, and can fix the file, but when I try to put my key file back, it doesn't work. I still get permission denied from the server on my local machine.

authorized_keys has the permissions 600. I have tried appending my SSH key with ssh-rsa and leaving the ssh-rsa off. I also tried making the SSH key all one line, but that didn't work either.

Is there something else that I have to do like reload the file some how?

  • 4
    Years later, this -still- seems relevant & active; only wanted to make an observation, talk about having had dodged a bullet: "Luckily I have an SSH open, so I am still connected [..]" - sheesh! ;dP
    – Nostromov
    Commented Mar 15, 2016 at 2:23
  • 2
    This post, which was edited on my birthday, saved me two months ago on my birthday.
    – rassa45
    Commented Aug 16, 2018 at 3:02

9 Answers 9


You should never save the file with its contents starting with -----BEGIN RSA PRIVATE KEY----- on the server, that is your private key. Instead, you must put the public key into the ~/.ssh/authorized_keys file.

This public key has the .pub extension when generated using ssh-keygen and its contents begin with ssh-rsa AAAAB3. (The binary format is described in the answers to this question).

The permissions of ~/.ssh on the server should be 700. The file ~/.ssh/authorized_keys (on the server) is supposed to have a mode of 600. The permissions of the (private) key on the client-side should be 600.

If the private key was not protected with a password, and you put it on the server, I recommend you to generate a new one:

ssh-keygen -t rsa

You can skip this if you're fully sure that nobody can recover the deleted private key from the server.

If this does not help, run ssh with options for more verbosity:

ssh -vvv [email protected]

On the server side, you can review /var/log/auth.log for details.

  • 1
    With Amazon EC2 servers all I get is the private key (key.pem). I don't have a public key anywhere.
    – Dave Long
    Commented Jun 1, 2011 at 17:04
  • 4
    @Dave Long: You must generate a new key using ssh-keygen -t rsa and put the newly created id_rsa.pub file in ~/.ssh/authorized_keys on your server. See also docs.amazonwebservices.com/AWSEC2/latest/UserGuide/…
    – Lekensteyn
    Commented Jun 1, 2011 at 17:33
  • 21
    @DaveLong: You can generate the public key from the private key at any time. You can do this simply with the following command: ssh-keygen -y -f key.pem > key.pub Commented May 17, 2013 at 0:40
  • 7
    @MorganBlackthorne While that is true, I would recommend generating your private keys rather than accepting one from remote sources. You cannot be fully sure that the private key did not get leaked.
    – Lekensteyn
    Commented May 17, 2013 at 8:49
  • 3
    @Gerrat Fixed².
    – Lekensteyn
    Commented May 31, 2014 at 19:59

An alternative way to install your public key in the remote machine's authorized_keys:

cat ~/.ssh/id_rsa.pub | ssh USER@HOST "mkdir -p ~/.ssh && cat >> ~/.ssh/authorized_keys"

Some advantages:

  • does not require ssh-copy-id to be installed.

  • guarantees that mkdir works before attempting to append id_rsa.pub to authorized_keys.

There is a chance that a newly created authorized_keys file or .ssh folder will not have the correct file permissions. This may result in ssh attempting to fallback to password authentication (if it is still enabled).

To fix this, log back in the server and run:

chmod 700 ~/.ssh && chmod 600 ~/.ssh/authorized_keys

See this answer for more details, as well as the other answer to this question.

  • 18
    Your answer helped me to do this on multiple remote machines without any additional packages, thank you.
    – nol
    Commented Mar 7, 2014 at 10:06
  • 1
    This doesn't guarantee that the "~/.ssh" directory and "~/.ssh/authorized_keys" file will be created with the correct permissions.
    – Nick
    Commented Jun 4, 2014 at 5:55
  • 1
    @Nick, I had that problem. So then perhaps one must really first check for their existence, if missing create properly with chmod (700/folder, 600/file), and only then add? so then maybe it can't be a one liner? Commented Aug 7, 2014 at 3:52
  • 11
    @AnneTheAgile I think changing the mkdir -p ~/.ssh part of the answer given by @MariusButuc to umask 077 && mkdir -p ~/.ssh is all you need to do to ensure that it will work properly.
    – Nick
    Commented Aug 7, 2014 at 14:02
  • 1
    ty @Nick! I will give it a go. Commented Aug 7, 2014 at 21:02

If you have login based authentication then use ssh-copy-id to append your public keys to remote server.

ssh-copy-id user@host
  • 1
    That doesn't seem to be a valid command on Mac, which is what my client machine is.
    – Dave Long
    Commented Jun 1, 2011 at 17:05
  • 1
    May be helpful phildawson.tumblr.com/post/484798267/ssh-copy-id-in-mac-os-x Commented Jun 1, 2011 at 17:23
  • 16
    on OSX you can install with brew: brew install ssh-copy-id
    – phil
    Commented Nov 21, 2013 at 0:26
  • On Macports, this command can be installed using sudo port install openssh +ssh_copy_id. The +ssh_copy_id installs openssh with the ssh_copy_id variant. Commented Sep 18, 2014 at 22:23
  • 7
    Note that the instructions on phildawson.tumblr.com ask you to install untrusted software, as root. This is quite dangerous and a good way to get hacked, unless you know you can trust the author. Commented Sep 18, 2014 at 22:24
local> scp .ssh/id_rsa.pub remote.com:
local> ssh remote.com
remote> cat id_rsa.pub >> .ssh/authorized_keys
remote> rm id_rsa.pub
remote> exit

Easiest way is to copy and paste...

First view/copy the contents of your local public key id_rsa.pub including the beginning "ssh-rsa" until it ends with your email address:

cat ~/.ssh/id_rsa.pub

Then edit authorized_keys on the server and paste contents of your clipboard below any other keys in that file:

nano ~/.ssh/authorized_keys

And save Ctl+O, exit the file Ctl+X, exit the SSH session exit and try logging back in to confirm it worked. If it didn't ask for a password it worked.

  • That's far from the easiest and begs mistakes to happen which will corrupt the file. catenating the key into the authorized_keys file is MUCH safer.
    – RichieHH
    Commented Nov 30, 2020 at 3:14
  • 2
    I disagree. It would take a lot of talent to mistype “cat” and highlight lines that were obviously not part of the file.
    – ow3n
    Commented Nov 30, 2020 at 13:20
  • 2
    It's good to know that it's no more than copy/paste into the auth keys file.
    – Danijel
    Commented May 11, 2022 at 12:51

Get a shell on the remote machine where you want to put the key and then you can run this one-liner to create the necessary files and directories, set their permissions and append the key to the file. Of course you have to change the KEYGOESHERE part below and the comment after it.

mkdir -p ~/.ssh && chmod 700 ~/.ssh && touch ~/.ssh/authorized_keys && chmod 600 ~/.ssh/authorized_keys && echo "ssh-rsa KEYGOESHERE user@remotehost or note" >> ~/.ssh/authorized_keys

I thought I can contribute to this since it is about AWS instances specifically and all the answers only treat the problem as a Linux issue, as if it was a piece of hardware. First thing you need to understand is that you should never, ever, don't treat EC2 instances as hardware. That's just going to create more work for you Treat them as volatile. That's the biggest hurdle I see people having with AWS. Make an AMI of your instance and inject the key you need into the new instance. cloud-init will take care of it for you. In more detail all you have to do is use the correct public key when creating the new instance out of the AMI of the original. If, like in the comments of the approved answer you want to generate your own key pair of pub and pem files AWS provides you with the option to upload your public keys for use in EC2.



After saving public key you should save the private key into a directory and file on your pc. And in the auth section of ssh on putty you should point to the private key file that you saved on your desktop. It will work. It works for me.

  • 1
    I would just love it if windows console could have all the ssh functionality added into it's interpreter
    – Dennis
    Commented Nov 9, 2014 at 1:46

Here's a variation whereby you might have a list of public key filenames in a text file and the big batch of public key files are also in the same directory.

This variation can be helpful if you were giving a huge list of public key files to import :-)

$ for i in $(cat ListOfPubKeyFiles.txt) ; do cat $i | ssh User@Hostname "cat >> ~/.ssh/authorized_keys"; done

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .