Some time ago I had two operating systems on my hard disk, Windows Vista and Windows 8 and I could double boot them. Windows vista was installed on the active partition (C:\ drive). Then I formatted the C drive (Vista partition) and installed Ubuntu 12.04 on it. Now I have GRUB on my MBR but I can't log in to Windows 8. To fix this I tried running bootrec.exe /fixmbr from the windows recovery console and it just made things worse. I lost grub, and then I could not log in to any operating systems and had to re install Ubuntu after that.

I want to boot Windows 8 also from it besides Ubuntu. How can I do it? I don't want to risk losing any of my data or installations, so please help me out. Complete information about the hard disk and installed OSs can be found here: http://paste.ubuntu.com/7445519/. Thank you very much. Any help is appreciated.

EDIT1: I tried the boot-repair utility. It created two new entries in the GRUB menu. One of them is my Windows Vista recovery drive (ignore it) and the other one is Windows 8 that I want to boot in to on /dev/sda5. Here's the complete report from that tool: http://paste.ubuntu.com/7445554/

  • finally problem is you cant boot into windows? and you have ubuntu installed. – Bibi424 May 11 '14 at 6:33
  • Have you tried running fixboot as well as fixmbr from the recovery console? fixmbr re-writes the master boot record, while fixboot writes a new partition boot sector to the system partition. – Gerowen May 11 '14 at 7:49
  • @Gerowen. Yes I also did that when I ran fixmbr but it didn't fix it. – qutab May 11 '14 at 13:22

Could you try boot repair whit sudo apt-get type:

         sudo apt-get-repository boot-repair && sudo apt-get update &&  sudo apt-get install -y boot-repair && boot-repair

follow the instruction it could might work.

  • Yes I tried it and now it gives me two new options in the GRUB menu. Seems like it recognized the OS on my windows 8 drive. But when I choose that option it doesn't do anything. Just a cursor blinks on the screen. Here's the information it gave me: paste.ubuntu.com/7445554 – qutab May 11 '14 at 14:16
  • Could you try to enter in the terminal: sudo grub-reconf – Michael May 11 '14 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.