3

I have intel i915 graphic driver. Sometimes I get black screen, I have a shortcut for sudo service lightdm restart but it doesn't fix black screen problem. How can I reload graphic driver?

EDIT: It happens during heavy load of CPU, once it happened while scrolling chromium page.

Output of xrandr:

 xrandr
 Screen 0: minimum 320 x 200, current 1280 x 800, maximum 32767 x 32767
 LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
    1280x800       60.0*+
    1024x768       60.0  
    800x600        60.3     56.2  
    640x480        59.9  
 VGA1 disconnected (normal left inverted right x axis y axis)
 TV1 disconnected (normal left inverted right x axis y axis)
 VIRTUAL1 disconnected (normal left inverted right x axis y axis)

EDIT2: Though I accepted the below answer which was posted by terdon , after I tested it many times I must note that it doesn't work.

How can I reload video driver when I get black screen?

1
  • When does this black screen happen? Is it after the computer has gone to sleep mode? I have a similar issue and have fixed it by creating a shortcut that runs xrandr to fix my resolution. Please edit your post and show the output of xrandr. I should be able to give you the right command.
    – terdon
    May 10, 2014 at 21:18

1 Answer 1

3

I don't know if this will solve your issue, you might have a different problem to mine. In my case, the black screen happens when the computer has been left alone for a while and the screen has turned off. While moving the mouse or pressing a key wakes it up, the screen remains black.

My workaround is to run an xrandr command that sets up my screen again. In your case, the command would be:

xrandr --output LVDS1 --auto

If that does not set up the correct resolution, use this one instead:

xrandr --output LVDS1 --mode 1280x800

However, that's hard to type on a black screen. So, make a little script that runs this command:

echo -e '#!/bin/bash\nxrandr --output LVDS1 --mode 1280x800` > ~/bin/fix_screen.sh

The command above will create a file in your $HOME/bin directory (if the directory does not exist, create it with mkdir ~/bin) called fix_screen. Now, make the script executable:

chmod +x ~/bin/fix_screen

Finally, assign a shortcut to it. Open the Settings dialog:

enter image description here

Then, go to Keyboard => Shortcuts => Custom Shirrtcuts and click on the + sign:

enter image description here

And then enter this:

enter image description here

Finally, choose a shortcut for it. Just click on Disabled and then type the shortcut you want:

enter image description here

Now, the next time you have this black screen issue, just use the keyboard shortcut and everything should be fine.

4
  • Thank you for answer. I ll try your method and let you know.
    – kenn
    May 10, 2014 at 21:50
  • Though I accepted the above answer, after I tested it many times I must note that it doesn't work.
    – kenn
    May 31, 2014 at 19:32
  • @kenn please edit your question and explain exactly how it doesn't work. I should be able to help you work it out. Please show me the exact script you used, clarify whether it is executable and whether it runs correctly when run manually.
    – terdon
    Jun 1, 2014 at 23:05
  • I made a script like xrandr --auto --output LVDS1 --mode 1024x768 I tested the script, it works ok, but when I get black screen, it's not working, I tried it a few times because facebook/lookback video gives me black screen.
    – kenn
    Jun 2, 2014 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.