I have this error here is my output:You are missing the following 32-bit libraries, and Steam may not run: libc.so.6.

I've tried all of the fixes listed on this page and they are either out of date or don't work with my arc.

nvidia gtx 750 ti ubuntu 14.04

    Running Steam on ubuntu 14.04 64-bit
    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(1398287272_client)
    /home/chris/.local/share/Steam/steam.sh: line 755:  6819 Segmentation fault     (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
    mv: cannot stat ‘/home/chris/.steam/registry.vdf’: No such file or directory
    Installing bootstrap /home/chris/.local/share/Steam/bootstrap.tar.xz
    Reset complete!
    Restarting Steam by request...
    Running Steam on ubuntu 14.04 64-bit
    STEAM_RUNTIME has been set by the user to: /home/chris/.local/share/Steam/ubuntu12_32/steam-runtime
    Installing breakpad exception handler for appid(steam)/version(1398287272_client)
    /home/chris/.local/share/Steam/steam.sh: line 755:  6946 Segmentation fault      (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

Update 1 Downgraded to 12.04 still receiving the same error.

Update 2 Tried to switch between drivers to download steam but no proprietary drivers where present in the additional drivers menu.

Update 3 Fixed! I couldn't boot into my graphics card so i started using nomodeset by hitting right shift tab to get into grub then editing my boot file replacing quiet splash with nomodeset. This got me booted but after installing the drivers on tty3 I still had the missing library error in Ubuntu. So I went to Mint Cinnamon 64. I installed the Nvidia drivers by dropping to tty1, stopping mdm, and making sure to take the 32 libraries when installing the driver. It made steam load perfectly well. I still have to edit the boot file to nomodeset to get it to boot properly, but I'll call it a win anyway.

1 Answer 1


I've got a similar card and no issues at all with Steam in 14.04. if 32 bit libc6 is needed, you can try the following:

apt-get install libc6:i386

Apart from that, have you installed Nvidia's proprietary drivers for your card? I think it's a must if going to play Steam games. I know nvidia's driver version 334 works with your card, but I'm not sure if 331 does (that's the version bundled with ubuntu 14.04). If not, you could use xorg-edgers PPA.

  • I tried to download the libc6:i386 it says I already have it but it's keeping a couple back? and that 3 aren't upgraded. I have installed and run 334 and it seems to be working. I have to fiddle with it at start up(change the quiet splash to nomodeset) but other than that runs fine. Just can't for the life of me figure out where or why steam isn't working.
    – user280064
    May 11, 2014 at 22:06
  • I've checked mine and there is also a libc6-i386 package. After installing both you should have /lib32/libc.so.6 and /lib/i386-linux-gnu/libc.so.6. My steam version is 1: and I think I installed it downloading the .deb from Steam's website. How did you install yours?
    – user683887
    May 11, 2014 at 22:21
  • I've checked and do have libc.so.6. When I tried to look up the steam version using steam --version it came back with none. I used the software center to download and install steam.
    – user280064
    May 11, 2014 at 22:28
  • It's strange as I installed steam the same day I made a fresh 14.04 install and it worked out of the box. Is yours fresh too or have you upgraded from 12.04? If not, I'd suggest you to purge your current steam install and give a try to the "official" installer from Steam's website...
    – user683887
    May 11, 2014 at 22:40
  • yea it's weird it was a fresh build and the first thing I put on it was 14.04. The noveau drivers worked alright I even downloaded and ran some games on steam. Then I upgraded the nvidia drivers and got this message. I'll give the official installer a shot, Thanks for the assistance man appreciate it.
    – user280064
    May 11, 2014 at 22:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .