I need to get the latest available version of an application called arm which is a terminal monitor for Tor.

The download instructions [on the application webpage][2] has a link to an older version that I can get through a package in Ubuntu. The latest version is available in the gitweb. I downloaded it by using snapshot and then tried to build it on Ubuntu 12.04 from its source by using (./configure && make && make install). I got an error that says bash: ./configure: No such file or director

Any idea how can I install the application from gitweb or how to get the latest version of the application that I want.

Thanks in advance!

  • You need to be in the same folder as the configure script. – hmayag May 10 '14 at 20:49
  • Maybe run setup.py? – enedil May 10 '14 at 21:09
  • Thanks for your solutions but none of them works for me. – Flora9 May 10 '14 at 21:57

There is no configure script in this program. Do that:

  1. cd into the directory of this application
  2. chmod +x ./install
  3. ./install

The install program will invoke the setup.py script appropriately. This assumes you already have all the dependencies necessary to build the program.

  • Thanks for your reply. Im still not able to get it installed when I tried what you just mentioned I got this error: "python: can't open file 'src/prereq.py': [Errno 2] No such file or directory." indeed, there is no folder or file that has that name in the folder that I got from gitweb! Here is the download instruction in the application webpage atagar.com/arm/download.php – Flora9 May 10 '14 at 21:54
  • From the website you pointed out, download the tarball. There exists a src folder. – thiagowfx May 10 '14 at 22:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.