0

I just installed ubuntu and im completly new with ubuntu.

I am trying to get my second harddrive to work but it won't.
I've used some guides like this
But still no success.

The problem is that it doesn't see my ntfs as a valid one.
I don't really understand what this means. this is the message the terminal gives me when trying to mount the hard drive:

robert@Robert-Linux:~$ sudo mount -a 

NTFS signature is missing.  
Failed to mount '/dev/sdb1': Invalid argument   
The device '/dev/sdb1' doesn't seem to have a valid NTFS.  
Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?  
robert@Robert-Linux:~$  

Hopefully someone can help me out.

Greetings Robert

EDIT

/etc/fstab file content:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=d91f5c8b-30d0-4bc7-85cb-e3b26d2e9c1d /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=81cc1c05-8435-4d18-8af5-049d092294cb none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

/dev/sdb1 /media/disk2   ntfs   defaults        0    0 
  • Robert, the article you linked to says to change the text file at /etc/fstab. Did you do that? If so, would you please post the contents of that file so we can help – user1477 May 10 '14 at 18:17
  • yes i did change that here is what is in the /etc/fstab file: /dev/sdb1 /media/disk2 ntfs defaults 0 0 For the full content of the file i edited the main question – user280219 May 10 '14 at 18:24
  • Signature missing is typically that is it not formatted even though partition table says it is NTFS. All NTFS partitions have to have a NTFS boot signature with start & size of NTFS partition. IF you resized it you need to run chkdsk. Or if you installed grub to sdb1's PBR partition boot sector then you need further repairs. – oldfred May 10 '14 at 18:34
  • ... then that partition isn't formatted as ntfs. – psusi May 15 '14 at 16:54