7

Good afternoon everyone! I'm going to be objective in my problem.

Before I was using Windows 8 on my notebok and ubuntu on the desktop. I decided to test the update 14.04 in the notebook, installed and worked perfectly, when one day I called and the sound wasn't working anymore, I went to look at the audio configuration and saw that he wasn't recognizing the audio card. Can someone help me?

$ aplay: device_list:268: No sound card found...

$ lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
    Subsystem: COMPAL Electronics Inc Device 0032
    Flags: fast devsel, IRQ 22
    Memory at f2a00000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>

00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03) (prog-if 00 [Normal decode])
    Flags: bus master, fast devsel, latency 0

Print the configuration

Print for my configs

5

I had the same problem. You can solve it using the following command:

sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2

Then just restart the computer.

| improve this answer | |
0

I'm running a different version of Linux (based on Ubuntu) but my problem turned out to be caused by hardware, so my solution may help somebody.

I'm running Linux Mint 18.1 Cinnamon on a Dell XPS 13 (9360). I had a similar problem; the sound stopped working and reboot didn't fix it. When I ran aplay I saw:

aplay: device_list:268: No sound card found...

It seems the XPS has bugs with the sound, sometimes triggered by plugging in headphones or by low power shutdown.

https://wiki.archlinux.org/index.php/Dell_XPS_15#Sound

https://bugs.archlinux.org/task/49157

What worked for me:

  1. Press F2 during startup to enter Bios

  2. In System Configuration > Audio, uncheck the box to disable sound entirely.

  3. Save the change and continue booting up.

  4. Restart the computer, enter BIOS again and now reenable sound.

  5. Save the change and continue booting up.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.