I'm using Ubuntu 12.04, and did not run on any major issues, until today. My logs showed that yesterday, May 9, 2014 my system performed an automatic dist-upgrade. With that dist-upgrade, it uninstalled WINE (1.6). So I cannot run WINE-based programs now. (I tried waiting for a day and repeatedly tried sudo apt-get update; sudo apt-get dist-upgrade without success.)

sudo apt-get install wine or sudo aptitude install wine does not install WINE, instead error like this is encountered:

The following packages have unmet dependencies: wine : Depends: wine1.6 but it is not going to be installed or wine1.7 but it is not going to be installed

Did anybody else experience similar breakage lately?

  • Are you using ppa:ubuntu-wine/ppa? If so, there was a new release of wine1.7 3 days ago. Perhaps it failed to upgrade on your system. Can you post the full output of apt-get install wine1.7? – bain May 10 '14 at 18:45
  • @bain Yup, I was using the ppa. Here it is: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: wine1.7 : Depends: wine1.7-i386 (= 1:1.7.18-0ubuntu1) E: Unable to correct problems, you have held broken packages. – Majal May 11 '14 at 0:47
  • @bain Another side problem... It also uninstalled Ardour. (Although I don't need Ardour as much as I needed WINE.) Strange... I don't do much tweaking in this machine since it's designed for production. – Majal May 11 '14 at 0:54


ppa-purge ppa:ubuntu-wine/ppa
apt-get update
apt-get dist-upgrade
apt-get install wine
  • Hi. Sorry, it didn't work. But here's an update. I also installed grive and grive-tools about that time, and I think it caused the mess. I uninstalled both. WINE will now install BUT... only version 1.4 ?!? Why? – Majal May 11 '14 at 14:36
  • wine-1.4 is the most recent version in the Ubuntu 12.04 repositories. You will need to re-enable the PPA to get a later version. – bain May 11 '14 at 14:39
  • Hi, I added the repo back, updated, requested install...: Still 1.4. With the install, it also requires to REMOVE packages such as: alien gnome-common google-earth-stable:i386 rhythmbox-plugin-complete. Hmmm... – Majal May 12 '14 at 1:03

After a few days, I think I found the source of the problem: certain packages that makes the system unstable. Find these, and remove them. In my case, I uninstalled grive and grive-tools, with the latter not being designed for Ubuntu 12.04. So even if their site said that they encountered no problems with it in their 12.04, I had it in mine.

Lesson (the hard way): If you need to maintain a production system that shouldn't break, try to stick closely to well tested repos rather than individual downloads of one or two packages from builds that are not designed for your system.

I was able to reinstall WINE after I removed programs that messed up the system. If you have this problem, search for those (esp. those you recently installed) and remove them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.