I use Xubuntu 14.04 64 bit. I was watching a movie, the desktop froze (as usual duh!), I logged out using a terminal, and couldn't log in to my account after that, I'm using a terminal.

I type my password, it seems to log in, then it logs me out again! I saw many questions like mine, they had brilliant answers:

  • logging in using tty! great idea, except that even in tty, I get the same error wrong password thing, there is no way to run anything that requires sudo!
  • Go to grub and do stuff! Great idea! except that I have hidden grub, it was annoying. Editing it requires sudo. Holding Shift shows loading grub but after that, it continues booting to xubuntu, as if I'm not pressing anything
  • Using live CD? I don't know about that, didn't try it, anyway I don't have the live CD, I gave it away and deleted the ISO, I have other CDs though, Debian, mint, arch and crunchbang.


I had boot repair disk, I used that to repair grub, then went to ubuntu recovery mode and

mount -rw -o remount /
passwd myaccount

I entered my password but I still have the same problem, I have another account myacount2 I can't login to that either, I can only login to guest

Update 2

I managed to fix myaccount2 which is my backup account by reseting the password, but I can't fix the main account, the problem could not be fix by simply resetting the password.

Update 3 I am now able to login to my account through tty, I also created myaccount3 with sudo privileges, I removed lightm and installed GDM, didn't fix it, reinstalled fglrx, didn't fix it, startx didn't work.

Update 4 I can confirm that it is xfce error, because I installed e17 and it's working now

  • I think something is wrong with xfce4-session – Lynob May 10 '14 at 18:13
  • Similar problem with unity. – Matías Guzmán Naranjo May 11 '14 at 15:28
  • @MatíasGuzmánNaranjo you could try the solution given in the answer, but everything will be gone, except the programs you installed, you have to set the desktop up again or you could install something other than unity – Lynob May 12 '14 at 13:50

You can login to the account through the tty, but when you try to do a graphical login, you get logged out and returned to the login prompt. You can do a successful graphical login with other accounts. This suggests a problem with a config file in your home directory, possibly your session file.

Try logging in to the account through the terminal and do:

 mv ~/.config/xfce4{,.bak}

This will move your XFCE config to a temporary location. Now try logging in again.

If that does not fix the issue, there is another option that will fix any login problem caused by a misbehaving home directory. Login again at the terminal and do:

mkdir ~/bak
mv ~/.* ~/* ~/bak

Try logging in again. It should now work (we know this should work, because you can already successfully login as another user - all we are doing here is resetting your home directory to a fresh user state).

Now take your files and config in the ~/bak directory and mv anything that you want in your home directory back there. Try to login. It's a process of trial and error - eventually you will find the script or config file that broke the login. Once you have identified the file causing the problem, you can remove that file, and restore all of your other files from ~/bak.

  • I will test your answer later tonight and report back, I can confirm that it is xfce error, because I installed e17 and it's working now – Lynob May 11 '14 at 16:55
  • It worked but I now have to get everything back again :( – Lynob May 12 '14 at 13:48

I have a little bit similar problem, i use ubuntu 12.04 LTS 32bit if my linux prompt me to upgrade to ubuntu 14.04.2 LTS i start that upgrade, in 50% of completion my notebook turn off like a crash and after hour i start linux and then i try to login and display flash 1x like a logging in and then i am back on login screen and guest session do that too

  • This is not an answer. – waltinator Jun 12 '15 at 22:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.