8

I want to use CUDA on my pc (using bumblebee), but whenever I want to start a cuda-driven program, I get the error modprobe: FATAL: Module nvidia-uvm not found. I already installed nvidia-337-uvm via apt-get, but nvidia-modprobe can not find the module. So, what am I doing wrong? System is Ubuntu 14.04.
Thank you!

5

I got the same problem on my machine, I find the solution here:

Edit the file /etc/modprobe.d/bumblebee.conf or create a new file if you are not using bumblebee and add a line to it:

alias nvidia-uvm nvidia-340-uvm

You should replace nvidia-340-uvm into the version you are using. You can find it by

sudo updatedb
locate --regex nvidia-.*-uvm.ko
| improve this answer | |
  • I have no bumblebee.conf – stiv Oct 16 '19 at 2:10
5

Thank you! But my string differs:

alias nvidia-uvm nvidia_352_uvm

Because:

$ locate --regex nvidia.*uvm.ko
/lib/modules/3.19.0-39-generic/updates/dkms/nvidia_352_uvm.ko
/var/lib/dkms/nvidia-352/352.63/3.19.0-39-generic/x86_64/module/nvidia_352_uvm.ko

Maybe it will help anybody more.

| improve this answer | |
1

Today, I came across a day fulfilled of PURGES and APTITUDE/APT-GET's. I was trying to fix the problem of activating the nvidia-uvm.

I have a CUDA 6.5 already installed. I updated my nvidia to 352 thinking that the 340 was with problems. But as you will see, it was a matter of activating components blacklisted by the bumblebee.

I run:

sudo apt-get install bumblebee bumblebee-nvidia

However, I decide to comment the following from file "/etc/modprobe.d/bumblebee.conf":

Workaround to make sure nvidia-uvm is removed as well

remove nvidia rmmod nvidia-uvm nvidia (commentted)

It was giving problems in my modprobe activation. First of all, I do not know why, but I have to, always, run the optirun command with some process and, then, execute sudo modprobe nvidia-XXX-uvm

EX: "sudo optirun glxspheres64 sudo modprobe nvidia-352-uvm"

I think it is because bumblebee blocks some component that should be activated when optirun is executed. Anyway, it worked for me and I hope can save some PURGE/INSTALL that everyone maybe be tired of executing.

Best wishes,

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.