0

Yesterday I was copying things from NFS to my computer and something was stuck, after a while I tried to restart my computer but it didn't work so i force powered it off.

Now, when I booted the machine, it got to GRUB and after it couldn't boot.

It seems like vmlinuz and initrd loading successfully (no matter what version - 3.13, 3.11 i tried both of them).

all i see at the beginning is empty screen and after a while it sometimes tells me that mount points are not ready (/tmp /boot /):

"The disk drive for [some mountpoint] is not ready yet or not present. Continue to wait, or Press S to skip mounting or M for manual recovery".

except for "/", it warns about all the mountpoints in fstab.

Also can see that "rpcsec_gss daemon" is failed to start.

At one of my attempts it told me that there are serious problems with /, so I used livecd and fsck the disk. didn't find anything special.

My questions are: 1. how can I debug the boot process verbosely and find what cause this problem? 2. what can cause this trouble?

By the way, i have Ubuntu 14.04

Thanks in advance

1

Fixed the problem!

It seems like it was because of ldap service. i've installed openldap client and changed /etc/nsswitch.conf file to load users first from ldap identities (for example passwd ldap compat).

When I removed ldap from nsswitch.conf, the system got back booting again.

the suspected messages found in /var/log/syslog:

"May 10 12:22:13 iLaptop kernel: [ 1237.108870] type=1400 audit(1399713733.676:43): apparmor="DENIED" operation="open" profile="/usr/sbin/cups-browsed" name="/etc/ldap/ldap.conf" pid=10490 comm="cups-browsed" requested_mask="r" denied_mask="r" fsuid=0 ouid=0" "

"May 10 12:22:14 iLaptop kernel: [ 1237.973672] type=1400 audit(1399713734.540:44): apparmor="DENIED" operation="open" profile="/usr/sbin/cupsd" name="/etc/ldap/ldap.conf" pid=10528 comm="dbus" requested_mask="r" denied_mask="r" fsuid=7 ouid=0 "

  • Of course I used liveCD in order to read the files. mounted "/" partition and then found log files. – idgar May 10 '14 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.