When I install "Installer for Microsoft TrueType core fonts" (ttf-mscorefonts-installer) from the Software Center on 14.04, it gives a positive response--but after this I get a download error. It seems that the files actually providing the fonts are never retrieved. Is there any way to resolve this?

  • 7
    Depends on the error don't you think? So please provide it :)
    – Rinzwind
    Commented May 10, 2014 at 7:36
  • Downloading wine from the software center (GUI based) doesn't seem to give the curses based EULA confirmation; or at least pops up windows that are hidden. It is very easy to get this particular package partially installed. Commented Nov 23, 2014 at 14:22
  • This is a good question with a good answer. Don't think it should have been closed. It helped me. Thanks!
    – Mark
    Commented Apr 18, 2015 at 1:35
  • @Eliah Actually, that other question would not have helped me since I was trying to install these fonts from the GUI package installer, and it never showed me a menu to accept the license agreement (probably the case for the OP here, too). This answer helped because it prompted me to attempt a command-line install, which then showed me the license agreement.
    – Mark
    Commented Apr 18, 2015 at 17:05
  • 2
    @Mark I now think you are right; I think we should not have closed this, and that its current closed status is likely keeping people from finding the help they need. While How can I accept the Microsoft EULA agreement for ttf-mscorefonts-installer? is related and potentially helpful, people are unlikely to get the answer to this problem from that question. Right now this is clear enough to remain open and also not a good duplicate of that other question. I've voted to reopen it. Commented Apr 18, 2015 at 17:38

6 Answers 6


The ttf-mscorefonts-installer package allows for easy installation of the Microsoft True Type Core Fonts for the web.

Run sudo apt-get install ttf-mscorefonts-installer and accept the EULA, or else if you already have ttf-mscorefonts-installer installed and you didn't accept the EULA, then uninstall ttf-mscorefonts-installer and reinstall it like this:

sudo dpkg -P ttf-mscorefonts-installer  
sudo apt install ttf-mscorefonts-installer  

Use the Tab and Enter keys to accept the EULA in the Microsoft TrueType core fonts window that pops up. The terminal will output a new message each time it finishes downloading a new font. Wait a bit until the terminal tells you that it's finished downloading and installing the Microsoft TrueType core fonts.

As noted in package ttf-mscorefonts-installer 3.4+nmu1ubuntu2 fails to install/upgrade, the current 3.4 version of ttf-mscorefonts-installer searches for the font files in an incorrect network location. The consequence of this is that the core fonts are never installed. This problem occurs with Ubuntu 16.04 as of July, 2016. Current to October 11, 2017 the latest version of ttf-mscorefonts-installer is also 3.4 in Ubuntu 16.10 and Ubuntu 17.04 and the latest version of ttf-mscorefonts-installer is 3.6 in Ubuntu 17.10.

The Debian (upstream) version 3.6 of ttf-mscorefonts-installer searches for the font files in the correct network location, and will successfully install the core fonts. For more information about this fix see Failure to download extra data files - ttf-mscorefonts-installer

  • 4
    There is a question about an additional problem with installing some Microsoft TrueType core fonts in Ubuntu 14.10. An answer to this question: Mscorefonts problems has the solution to this problem in Ubuntu 14.10.
    – karel
    Commented Oct 30, 2014 at 17:27
  • 6
    Comment from anonymous user: I've just had the same problem, but I found that it may possibly be a network problem. Regions such as China can hardly connect to Ubuntu mirrors. As a result, the script would timeout while downloading those files. After I connected to a VPN and started the script, the problem went away.
    – Fabby
    Commented Jan 4, 2015 at 12:50
  • 1
    Almost no one will understand the context and the purpose of the answer unless I repeat the original question which is as follows: When I install "Installer for Microsoft TrueType core fonts" (ttf-mscorefonts-installer) from the Software Center on 14.04, it gives a positive response--but after this I get a download error. It seems that the files actually providing the fonts are never retrieved. Is there any way to resolve this?
    – karel
    Commented Apr 18, 2015 at 17:33
  • 1
    @karel Good point. How can I accept the Microsoft EULA agreement for ttf-mscorefonts-installer? really is a different question. I shouldn't have voted to close this, and I've now voted to reopen it. Depending on the cause of this problem (e.g., is it just a 14.04 bug?) this might eventually be reclosed as off-topic, or perhaps the question asking explicitly about accepting the EULA will eventually be expanded and this will be a dupe, but right now this does seem wrongly closed. Commented Apr 18, 2015 at 17:35
  • 1
    Having experienced this problem myself, I can report that in my case it was not a bug because the EULA agreement window was there all the time, but it was covered up by the open window of the Ubuntu Software Center. After a moment of confusion, I minimized the Software Center window and there the EULA was. That's where the idea for my answer came from. At the time I was installing Xubuntu on someone's XP computer after refurbishing its hardware. So if there was a bug in my case, I would attribute the bug to problems with legacy hardware. There also may be other possible explanations though.
    – karel
    Commented Apr 18, 2015 at 17:48

Here's a work-around until the package is fixed:

TMP=`mktemp -d`   
cd $TMP
grep Url: /usr/share/package-data-downloads/ttf-mscorefonts-installer | awk '{print $2}' | xargs -n 1 wget  
sudo /usr/lib/msttcorefonts/update-ms-fonts $TMP/*  
sudo dpkg-reconfigure ttf-mscorefonts-installer  
cd -  
rm -rf $TMP

Note that this does skip the hash sum check, but they're just fonts, It's not like someone's going to hijack the download.sourceforge.net DNS and use it to distribute invalid files. The files aren't being executed: the update-ms-fonts script uses cabextract to pull the TTF files out of each exe.

Anyway, hope this helps.

  • I like the pragmatism, but someone very well might poison the fonts. I'll just take mine from my windows 10 install
    – MrMesees
    Commented Nov 25, 2016 at 12:25
  • 1
    You can check the sums manually they are in /usr/share/package-data-downloads/ttf-mscorefonts-installer. When you use sudo dpkg-reconfigure ttf-mscorefonts-installer you can point the installer to the dir where you have downloaded the exe files.
    – robkorv
    Commented Nov 25, 2016 at 13:47
  • Please add line: sudo dpkg-reconfigure ttf-mscorefonts-installer before "cd -" command and solution absolutely works. Also it may make bash script as completely solution.
    Commented Nov 27, 2016 at 15:46
  • Thank you, works for 18.10 cosmic desktop.
    – netom
    Commented Nov 3, 2018 at 12:19
  • Thanks a lot! Worked for 20.04 Focal desktop as well.
    – Eduardo
    Commented May 7, 2020 at 18:15

I was getting hashsum errors from arial32.exe package and the install would fail, but utilizing a combination of the two above me, this actually worked.

sudo dpkg -P ttf-mscorefonts-installer
sudo rm -rf /var/lib/update-notifier/package-data-downloads/partial/*
sudo apt-get --purge --reinstall install ttf-mscorefonts-installer
  • 2
    andale32 still not resolving for me.
    – Zlatko
    Commented Jan 24, 2017 at 16:36
  • Still getting the error "W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)" But all the fonts got installed successfully. e.g. see below log about Andale font. I'm able to use all the fonts in LibreOffice Writer as expected. Thanks a tonne! Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/andale32.exe... All done, no errors. Commented Mar 18, 2018 at 1:45

16.04 is affected by a download bug

More details in the bug report. As a workaround, download the revised Debian package and install it.

cd ~/Downloads
wget http://ftp.us.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb
sudo gdebi ~/Downloads/ttf-mscorefonts-installer_3.6_all.deb

These two commands worked for me:

sudo rm -rf /var/lib/update-notifier/package-data-downloads/partial/*
sudo apt-get --purge --reinstall install ttf-mscorefonts-installer

source: https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1371783


This worked like a charm: First, you need to delete everything related to msttcorefonts. Then this:

wget http://ftp.de.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb
sudo dpkg -i ttf-mscorefonts-installer_3.6_all.deb
sudo fc-cache -f -v

It works too in Linux Mint 18 :)

  • this also worked for me on ubuntu 16.04 thanks!
    – JREAM
    Commented Jan 17, 2017 at 8:30
  • +1, works here as well. @Ronald, what's the fc-cache doing?
    – Zlatko
    Commented Jan 24, 2017 at 16:38
  • Hi @Zlatko fc-cache scans the font directories on the system and builds font information cache files for applications using fontconfig for their font handling - according to linux.die.net/man/1/fc-cache
    – falconR
    Commented Mar 11, 2017 at 2:12
  • on Ubuntu 17.10 the solution also works Commented Nov 3, 2017 at 22:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .