4

I need to get into recovery mode but pressing and holding shift does not work during boot, I also tried tapping shift and f8 but nothing happens, any suggestions? My system runs ubuntu 14.04 and here is my grub file:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=5
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
  • Did you install GRUB? Are you having dual boot system? Kindly provide these details to help you solve the issue? Also provide information about you installation procedure and how many HDD are there in your system? – user279883 May 10 '14 at 1:18
  • Duplicate of I cant get grub menu to show up during boot. You need to remove both the HIDDEN items in /etc/default/grub and run sudo update-grub. This happens if you followed upgrade paths to 14.04. – artless noise Nov 28 '14 at 19:43
1

If the keys aren't working, you can actually edit the grub config file so that there is a little bit of a timeout for you.

sudo gedit /etc/default/grub

Change the value of GRUB_HIDDEN_TIMEOUT to a number in seconds. For example if you change it from 0 to 10, it will display the Grub menu for 10 seconds before automatically booting the first option.

Once you have made your desired change and saved the file, close it and run the following command to apply the changes:

sudo update-grub

After that

sudo reboot
  • Changed it nothing happens still.. – Cisum Inas May 10 '14 at 10:23
  • GRUB_HIDDEN_TIMEOUT is badly documented: "when this feature is unset (default), the menu will be displayed, and when it is set, the menu will not be displayed." – bain May 10 '14 at 12:59
  • Also note from info -f grub -n 'Simple configuration': GRUB_HIDDEN_TIMEOUT This option is unset by default, and is deprecated in favour of the less confusing GRUB_TIMEOUT_STYLE=countdown or GRUB_TIMEOUT_STYLE=hidden – bain May 10 '14 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.