6

I am experiencing shutdowns of my pc due to overheat of CPU. Running the command "sensors" I got the following output

Adapter: Virtual device
temp1:        +66.0°C  (crit = +101.0°C)
temp2:        +66.0°C  (crit = +101.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +61.0°C  (high = +105.0°C, crit = +105.0°C)
Core 1:       +61.0°C  (high = +105.0°C, crit = +105.0°C)

As you can see high and crit temperatures have the same threshold (105.0°C) I am wondering if maybe fan do not speed up to cool the CPU since it waits to reach the high threshold that is the same threshold that will shutdown the PC.

How could I set the high threshold to the correct temperature of 70°C?

  • Is there something in the BIOS ? – TuKsn May 9 '14 at 23:27
3

With command:

sudo sensors -u coretemp-isa-0000

You can see what options are available for each physical chip.

Create file in /etc/sensors.d/:

sudo touch /etc/sensors.d/isa-coretemp

then edit new file with:

chip "coretemp-isa-0000"
   label temp2 "Core 0"
   compute temp2 @-20,@-20 

   label temp3 "Core 1"
   compute temp3 @-20,@-20
  • Line label temp2 "Core 0" only change label;
  • Line compute temp2 @-20,@-20 reduce high temperature of 20 degrees (first @-20) and critic temperature also of 20 degrees (second @-20)

Now, typing sensors you should see the new settings.

Note

Refer to man sensors.conf:

Only  certain  chips  support thermal sensor type change, 
and even these usually only support some of the types above.
Please refer to the specific driver documentation to find out which types
are supported by your chip.

In theory, the BIOS should have configured the sensor types correctly,
so you shouldn't have to touch them, but sometimes  it isn't the case.
  • It does not work, I can only adjust input temperature and set high=crit temperature... Only these two parameters can be set, no additional parameters are accepted... – giuseppe May 10 '14 at 12:22
  • Ciao @giuseppe :). Absolutely. Then I edited my answer by adding a note. – girardengo May 10 '14 at 12:54
  • From the BIOS I cannot change any options. The problem is that my fan does not reach the maximum speed, even if the temperatures are very high... In older Ubuntu versions (10.10 and previous) all was working pretty fine, but than I had ATI drivers problem (that appear to be solved with Ubuntu 14.04) and now CPU overheating problems... – giuseppe May 10 '14 at 13:31
  • Did you try to configure with fancontrol askubuntu.com/a/46135/265974 – TuKsn May 10 '14 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.