I've been trying to install Ubuntu and/or it's derivatives on my new Dell Vostro 3550 but I'm finding it impossible to boot into the live CD environment. Here are the things I've already tried:

  • Booting from multiple versions of multiple distributions (Ubuntu 10.10, Ubuntu 11.04, Mint 11, Mint 10)
  • Booting from a Live USB created with unetbootin, the Linux Mint startup disk creator, the universal USB creator and dd of=linuxmint.***.iso if if=/dev/sdx.
  • Burning a CD and booting from the internal CD drive.

In the case of the USB keys with the latest versions of Ubuntu it gets to the page where I can select a boot option, but after selecting an option the screen goes black, even the back light turns off. With the older distributions the screen stays on but it starts loading and then just hangs.

The CDs don't even try to boot. It starts spinning but then falls back to the default Windows install.

The only way I've got it to work so far is with Wubi, but that's hardly ideal. I'd like to have two separate physical partitions with a /home and /.

Any help is appreciated. Thank you.

  • Did you try booting with the USB/CD on some other machine? Did it work there? – Nitin Venkatesh Jun 1 '11 at 8:57
  • Yes, they seem to be in working order. – rich97 Jun 1 '11 at 10:11
  • Did you check your bios boot order? Make sure it the first preference is CD/DVD drive or a usb drive. – Mad-scientist Jun 3 '11 at 7:55
  • Maybe an acpi related issue too. Try to boot via usb and at the boot menu choose the option that allows you to specify kernel parameters. At this point append acpi=off and see if it boots. – Paolo Jun 24 '11 at 17:51

I've gotten Ubuntu 10.10 running on a new Vostro 3550, but there are still a few issues: e.g. I get sound from the headphone jack, but not the speakers.

To get 10.10 installed, I used a live image on a USB stick (thumb drive).

Strangely, the installation worked when I inserted the USB stick into the eSATA/USB port, but not when I inserted it into the USB port on the right side of the computer. (That port has a strange symbol indicating that it is no ordinary USB port, but I'm not sure what it means)

| improve this answer | |
  • 1
    This is probably because the port that doesn't work is USB 3.0. It's been reported that this is an issue for Ubuntu 10.10 USB images, but it works fine once Ubuntu is installed: ubuntuforums.org/showthread.php?t=1628665 – 719016 Jun 12 '11 at 5:50
  • This was the problem for me right here. But as you say there were still a lot of problems. If you want the latest version of Ubuntu and don't mind installing a derivative then give Pinguy OS a go. Aside from the switchable graphics everything is working and I actually have a usable computer now. :) – rich97 Jun 12 '11 at 15:47

I am having the same problem : my Vostro 3550 will not boot Ubuntu 11.04 neither in amd64 nor in ia32 versions, and not install Ubuntu 11.04 (I tried both architectures) from my EMTEC 4GB - which works perfectly everywhere else.

The reason why the CD/DVD does not boot might be by design, for security reasons (you cannot boot ophcrack from it, for instance). However this seems contradictory with both the BIOS and the F12 key choice allowing you to select your boot device. And anyway the administrator should have the last word about whether (s)he wants to allow it or not.

Any feedback, somebody ? Ubuntu 11.0 worked beautifully on my preceding Vostro (3500, not 3550) : I cannot believe there is such a regression from the 3500 to the 3550. Any hint ?

Edit :

  1. MD5 checked and OK.
  2. CD burning checked and OK.
  3. Dell tests from the BIOS menu passed OK.
  4. Boot order : 1. CD, 2. USB drive and 3. HDD.

Second edit : Though I understand it would be hazardous in production mode, I made a DVD of the NIGHTLY BUILD of the future Ubuntu 11.10, and this time it installs quite well on the Vostro 3550 ! :-) Of course, as it is just an alpha or whatever, some functionalities are not fully operational, especially concerning multimedia; but to write and execute Perl, PHP or HTML with SciTE, things are quite OK and this is what I was most interested in. Skype works for me as far a sending SMS is just what I need. Things are good enough for me, now, and I can wait till October for what is missing. By the way, the Vostro 3550 is blazingly fast compared to my former Vostro 3500 !

Third edit : Looks like it is possible to boot a live CD if you replace "AHCI" with "IDE" in the BIOS SATA mode. However, this does not seem to be of much help, because in such a cas the hard disk does not seem to be accessible. Still investigating, 28 June 2011.

| improve this answer | |

"It starts spinning but then falls back to the default Windows install." Just to make sure - did you select explicit booting from CD? I had no problem with booting 11.04 and 10.10 from CD on my Vostro 3550. (10.10 seems not having drivers for wifi - only eth0 was working).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.