I am having difficulties loading multiple photos directly from SD card onto facebook. It works fine when I select one photo at a time. When I select more than one it does not upload the photos into my facebook photo album. I tried loading multiple photos from F-Spot onto facebook but have a similar experience. In both instances it only loads one photo at a time which is extremely time consuming.


5 Answers 5


Shotwell on Maverick does it auto-magically. Just select your photos, click on Publish, select Facebook and done.

I have found a PPA that will let you install Shotwell 0.72 (Maverick's version) in Lucid.


Someone has created a script that let Nautilus update a bunch of pictures to Facebook. There is small article in OMG! Ubuntu about it.


It's not completely clear /how/ you're uploading the files. Facebook has a Java-based uploader which allows you to not only specify multiple files, but will also locally scale them down before upload for a quick process.

  1. Make sure Java is installed (sudo apt-get install sun-java6-jre and make sure you have the "partner" respository ticked).
  2. Go to facebook, login.
  3. Click "Profile"
  4. Scroll down on till you see the "photos" box on the left pane. Click on the "See All" link.
  5. Click "Upload photos" to create an album, or click on an existing album, then choose "Add Photos".
  6. Finally, click on the "Java Uploader" text at the bottom, where it talks about "Troubleshooting".

It shouldn't be this difficult, but Facebook's obtuse interface doesn't make much easy.

  • I ran the command line and got the following: Reading package lists... Done Building dependency tree Reading state information... Done Package sun-java6-jre is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package sun-java6-jre has no installation candidate
    – namkid
    Sep 27, 2010 at 6:00
  • As for steps 2 -6, I have followed the steps and can only manage to upload one photo at a time.
    – namkid
    Sep 27, 2010 at 6:03
  • 1
    As I mentioned really briefly - you need to enable the "Partner" respository to install Java6. Sorry I wasn't clearer. Pop into Synaptic and give it a tick under "Repository".
    – Scaine
    Sep 27, 2010 at 13:02

I use the Picasa Facebook uploader on my Mac which works great. According to the developer it is not yet ported to linux.

However, I ran into a thread on the Ubuntu forums about using Picasa and Internet Explorer under the same WINE root in order to take advantage of the Picasa Facebook uploader. I haven't tried it yet and the thread is a year old. May be worth taking a look at. http://ubuntuforums.org/archive/index.php/t-1093761.html


I use digiKam (a KDE app, though I use Gnome) and under the Export menu you can export to a dozen or so websites, including facebook. Nice and simple. It does a resize before upload aswell, which helps with the time required.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .