Worked fine before, but since upgrading to Ubuntu 14.04 LTS, whilst the connection shows in Finder OK when clicking on it says "Connection failed to “XXX's remote desktop on Xxxxx”. The software on the remote computer appears to be incompatible with this version of Screen Sharing."

Desktop Sharing Preferences set to allow sharing and a password is requeted.

Everything else seems OK. Anyone got any ideas?



Using a combination of clues from http://discourse.ubuntu.com/t/remote-desktop-sharing-in-ubuntu-14-04/1640 (which is all about VNC access) and https://bugs.launchpad.net/ubuntu/+source/vino/+bug/1281250 (which discusses the bug introduced into Vino) I have managed to resolve the matter.

Essentially you have to disable encryption on remote desktop access in Gnome due to a bug that has come to surface in Vino. However some threads tell you uncheck it in the wrong place. Follow these guidelines and you should be able to resolve it quickly.

Specifically it's

dconf > org > gnome > desktop > remote-access > require-encryption - uncheck

and NOT

dconf > desktop > gnome > remote-access > enabled - uncheck

Here is how you do it:

  1. First make sure Desktop Sharing is set up properly.
  2. Download dconf-tools by typing in Terminal sudo apt-get install dconf-tools
  3. Run dconf-editor
  4. Expand org
  5. Expand gnome
  6. Expand desktop
  7. Select remote-access
  8. Uncheck require-encryption (don't click on Set to Default as it rechecks it)
  9. Exit dconf-editor

It should now work. Tested through a reboot and all good.

Hope it helps.

(I have got a screen shot of dconf but don't have enough points on here to post it - I am sure everyone can work it out for themselves though! :-) )

  • 3
    Fixed it for me as well. Thanks! Would be nice if the was a way (maybe there is?) to support encryption on the OS X side
    – Adam Carr
    Jul 13 '14 at 22:46
  • 36
    simpler just by typing gsettings set org.gnome.Vino require-encryption false for disabling encryption on Ubuntu side
    – Raffi
    Sep 23 '15 at 18:49
  • 4
    Even after disabling "Require Encryption" and rebooting my Debian machine, I can't get OS X El Capitan to connect. Screen Sharing just hangs after asking for my password of vnc://192.168.X.Y:5900. The app Chicken of the VNC does work, though.
    – jamshid
    Dec 9 '15 at 2:44
  • 1
    This advice is still current at the time of writing this, thank you! A couple of additional discoveries, since my connection to the Ubuntu remote was hanging on my host macOS: 1. In dconf-Editor, I needed to uncheck "prompt-enabled" 2. I also needed to modify "authentication-methods" to ['vnc'], and in the Desktop Sharing application I needed to set a password.
    – Chris
    Dec 19 '17 at 0:51
  • 1
    In my case my problem was that I plugged the LAN ethernet into a different port. When screen sharing is enabled in Ubuntu 18.04 it needs to be activated for a specific interface. Setting the 'network-interface' to '' in didn't actually cause it to listen on all interfaces, apparently. Aug 1 '19 at 1:28

From Raffi's comment and LinuxConfig.org. Tested on Ubuntu 18.04 and 20.04.

$ gsettings set org.gnome.Vino require-encryption false

then verify the setting with

$ gsettings list-recursively org.gnome.Vino | grep encrypt

See also How to set up Vino password via command line

  • I want to thank Afriza N. Arief for this answer. It got a production financial system back up and running. Deeply appreciated.
    – smcracraft
    Dec 29 '20 at 15:19
  • 1
    So you are running production financial system without encryption now? What can possibly go wrong...
    – jayarjo
    May 4 at 10:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.