I can't install ubuntu 11.04 on acer aspire one 722, this netbook using AMD A50M Fusion Chipset and ATI Radeon HD 6250 Graphics with 256MB of dedicated system memory.

Anyone can help me?

edit : ok I think I found a little bit of the problem. I try Install Ubuntu 10.10 and it's worked. But when I Install Ubuntu 10.10 netbook edition, I can't load my ubuntu (after choose a ubuntu from GRUB loader). Maybe the problem is unity system or something like that.

  • 2
    What do you mean by "can't install"? Jun 1, 2011 at 7:25
  • 1
    If you want from us to help you, you have to tell us where did installation stuck. :)
    – kv1dr
    Jun 1, 2011 at 8:29
  • Provide the following info please - 1) How did you download the image? Torrent or direct download 2) How did you install? CD or USB? 3) Are you doing an upgrade or fresh install? 4) Which step of installation did you get stuck up on? Jun 1, 2011 at 9:00
  • @nickguletskii : I mean installation stuck @kv1dr & @nitstorm 1. I download using direct download 2. live USB 3. It's a fresh install 4. installation stuck at copying ile, but it's random sometimes, when I try live USB, sometimes it stuck like hang btw thanks for the attention
    – neyz
    Jun 1, 2011 at 11:58
  • @neyz: could you please check the MD5 of the image you downloaded? Jun 2, 2011 at 7:20

6 Answers 6


Update: I've posted a short solution as a separate answer. Following in this answer is what I suggested before I came to it.

The problem is with Wi-Fi definitely!

After a day of testing every possible way (64 and 32 bit, standard and alternative versions of 10.04, 10.10, 11.04) to install Ubuntu on my Aspire One 522 (same chipset and same C-50 Fusion processor) I finally found a solution on how to install and run it, thanks to your assumptions on the wi-fi adapter.

The problems I had with all versions of Ubuntu were that they all hung in some starting phase of installation when the wi-fi led began to blink. So assuming that was the problem I started looking for a way to turn this damn thing off, but there was no physical switch for that on this model and the Fn+F3 seemed to work only when the driver was up and running on Windows. The solution I found was to simply plug the laptop to LAN with a cable. Thus I successfully installed 11.04 32 bit and was able to boot into 11.04 64 bit setup but just didn't have time to install it.

So now I'm able to run Ubuntu okay but only with the LAN cable plugged in - as soon as I detach it after a couple of seconds when Ubuntu starts to scan wi-fi networks it hangs. So now I'm looking for a solution on the Wi-Fi driver.

P.S. Also I'd like to inform you guys that I was able to install Fedora 15 32-bit edition with absolutely no problems: both bluetooth and wi-fi worked with no problems. The 64-bit Fedora I could not, though I didn't try as hard as with Ubuntu ). So if nothing works out we can always swithc to Fedora. Guess we can also find out which driver Fedora uses for this piece of ...wi-fi.

Update. Now that I've tried reinstalling the 32 bit Fedora, which previously worked just fine, the same thing happened in it. I've also been able to install Fedora 64bit and Ubuntu 64 bit with a described method. I tried upgrading to latest 3.0 kernel, but every single distribution I've installed suffers from exactly the same problem with the wireless module. Btw, in my case it wasn't a Broadcom, but Atheros AR9285. If you have the same one this could probably be a solution for you: System freeze caused by ath9k driver

As for me I say fork this sheet I go back to Window monster! At least I can watch videos there. Btw wtf is wrong with AMD and their ATI drivers support?! Are they lazy or just stupid? Man, I'm really disappointed with all this story.

  • cool mojo.... you're right, the problem is with wi-fi driver. Thanks a lot
    – neyz
    Jul 12, 2011 at 0:14

I read this somewhere else that I can't remember so I can't take credit for it. If you set your network device as boot option number one in the BIOS then it will work (don't know why either). I'm currently running 11.04 on a aspire one 722. Also, I think I used the alternate installer to avoid any freezes during installation.

  1. Turn on Network Booting feature in Bios
  2. Move Network boot to first place in boot priorities in Bios
    • Tested on Ubuntu 11.04 32 and 64 bit and Fedora 32 and 64 bit.

After two days of trying all possible distros, 32 and 64 bit, updating kernels and I accidentally tried this and this was the only thing that worked )

  • It doesn't seem to work for me purely based on changing the boot order. In my AO722, I actually have to leave the Ethernet wire pluggined in until it finishes booting before unplugging. There is a difference in the hardware though. Even though mine is advertised as C-50, the actual CPU is detected as C-60 (in BIOS, and under OS itself)
    – Antony
    Aug 31, 2011 at 0:16

i can install it successfully (ubuntu 11.04 32bit), but then when i tried to run it, after the login screen; it s just frozen.

the ubuntu 11.04 64 bit cant install at all.

(i am sure that i have my installation usb finem i created it from ubuntu menu start up disk creator)

  • hmmmm maybe ubuntu 11.04 can't detect AMD APU Chipset T.T
    – neyz
    Jun 6, 2011 at 4:45

I encounter the same issue. Actually for me it seems to be related to the wireless driver. If I boot the netbook with disabled WiFi, everything works fine.

  • hmmm wireless driver ? try install broadcom driver from restricted driver manager, maybe your problem is solved
    – neyz
    Jun 20, 2011 at 4:20
  • read my conclusion for wireless problem
    – neyz
    Jun 28, 2011 at 18:49

OP posted:

prologue : read this if you want to know why I try some eksperiment (upgrade kernel) for this netbook

After doing some eksperiments using several ubuntu distributions and debian, I have the best distribution for Acer aspire one 722. First of all, this is my trial and error eksperiment :

  1. Ubuntu 10.04 LTS (32 bit & 64 bit) -> Worked after Install, but unstable for video card driver and lot of bug. After I upgrade the OS, I got freeze state.
  2. Ubuntu 10.10 (32 bit & 64 bit) upgraded to kernel 2.6.36 -> stable for video card, but freeze state if you turn on the wifi (for ubuntu 10.10, after install the classic version, )
  3. Ubuntu 11.04 (32 & 64 bit) & Ubuntu 10.10 netbook edition -> freeze state after fresh install
  4. Debian fresh install & upgraded to kernel 2.6.38 stable -> stable but... not the best performance for this video card

Conclusion : the problem is around fglrx driver, unity, and broadcom driver (thanks @Andreas Kammlott for your information).

The best way for my acer aspire one 722 (stable system, video card worked and stable, wi fi worked and stable):

  1. OS : Ubuntu 10.10 kernel 2.6.35-28-generic

  2. AMD driver using AMD Catalyst™ 11.6 Proprietary Linux x86 Display Driver

note :

  1. linux not fully supported AMD APU architecture, I try windows 7 at this netbook and the result is very awesome. I hope at linux version 3, AMD APU architecture can be fully supported
  2. Don't Install ubuntu netbook edition package !!! or your OS will get freeze state =)

The solution is here: http://bernaerts.dyndns.org/linux/202-ubuntu-acer-ao722

Not the answer you're looking for? Browse other questions tagged or ask your own question.