I've been trying to install Ubuntu 14.04 on a new Lenovo G 50-70. However upon installation on boot-up the system goes into the following error

The system is running in low graphics mode.

I've tried the fixes mentioned on this page How to fix "The system is running in low-graphics mode" error?

sudo apt-get install fglrx

But it relies on internet connectivity as in the command relies on the system being connected to the internet. This machine does not have a RJ 45 lan socket and doesn't seem to detect a Wifi. I tried using the iPhone as a hotspot and even that failed. Any help to get Ubuntu up and running would be appreciated.


Lets focus on getting you connected, things will be easier then.


The chipset of your laptop should be supported. Could you paste the output of lspci and iwconfig

Wired Ethernet

There should be a LAN port on your laptop, but it seems to have an additional cover. Have you had a look at the port between your VGA and DisplayPort. Can that be flipped open?

Thinkpad G50-70 ports


Answering the second part aboout the wifi, first:

The problem is that the current Ubuntu image for 14.04 is missing the wifi driver for the card in your laptop (RTL8723be). The driver is included in the updates, but you have to use an ethernet connection to update your installation.

Alternatively, you could try to download the new driver manually from another computer. Should be in the package linux-firmware and install it from a USB stick.

Otherwise you have to wait for the next iteration of the 14.04 image, something like 14.04.1, where the driver will be included.

With wifi connection you should be able to get the video driver, without a problem.

  • 1
    I confirm no driver in 14.04.1 either. – Umair A. Dec 15 '14 at 18:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.