0

on my server i am using openvpn, owncloud and web server. i recently install sslh for using owncloud with https. i install sslh successfuly and make the configurations. problem is i am try to start sslh service but i get this error : xx.xx.xx.xx:https:bind: Address already in use. i now the problem but i can't fix it yet. if stop the openvpn services sslh work fine but after that i can't start openvpn service again (without reboot). i try to change boot order (change Sxxsshl number and make it smaller than openvpn' in /etc/rcx.d folders ) but it didn't work. so i am out of option and wait for help.

0

Are you sure you hasn't configured BOTH sslh and openvpn to use port 443? Please check it. Proper way would be to set up openvpn to listen on some other port (say, 0.0.0.0:18000) and configure sslh to redirect openvpn connections to 127.0.0.1:18000. This way you will be able to connect to openvpn directly should sslh fail for whatever reason, but also will be able to use sslh to serve openvpn on port 443.

Also, you might want to post your config for both here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.