5

I am running 12.04 LTS, fully updated. My system is configured to automatically log me in into my account. Auto-login works fine.

However, sometimes I need to access the unity-greeter/lightdm login screen. For example, this happens when I log out and then want another user want to log into their account. The interface we get is exactly the one shown on the Wikipedia page for LightDM:

  • the password prompt is grayed out and I am unable to type my password
  • the mouse moves fine but I cannot click the system icons on the top-right corner of the menu bar does not work
  • I can switch using ctrl-alt-f? to a console and login fine using the text/console login prompt. If I kill X, I am again returned to the same unusable login screen.

How can I fix this? How can a user log into their graphical environment without having to reboot the system?

4

I have encountered the same on random occasions on my 14.04 LTS installation. I have not been able to reproduce it. Sometimes it just happens and I am stuck at login.

I have added this alias to to my .bash_aliases file as a workaround that have worked so far:

alias saveme="export XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0 && dm-tool switch-to-greeter && logout"

When login prompt is grayed out. I switch to e.g. tty1 with Ctrl+Alt+F1, login and just enter my alias: saveme.

This way you will not lose any work from open applications. When you restart lightdm you will lose everything you had running which was really annoying and something I wanted to avoid..

XDG_SEAT_PATH may not be the same for you. Check while logged in in a terminal:

env | grep -i XDG_SEAT_PATH

You can also check with:

dm-tool list-seats
0

According to the bug reported at Launchpad.

The bug has been fixed in an updated version of Unity: 7.2.4+14.04.20141217-0ubuntu1. This fix should be included in 15.04 release as well.

0

The bug is still present in 16.10. I usually ssh from another machine, kill the gnome-screensaver process and that returns me to my session. No need to reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.