1

This is a variant of the unresolved https://askubuntu.com/questions/295610/cannot-find-name-for-group-id-26739201 but I'll post it here again since I have some more information

I recently made a fresh installation of 14.04 so most things "should" be clean.

When I open the terminal, I get this error message

groups: cannot find name for group ID ######

The group number changes every time I log out and log in again:

###### = 1097638658
###### = 1097638674
###### = 1097638677
###### = 1097638680
###### = 1097638683
###### = 1097646472 (here I also rebooted)

on subsequent logins.

At the same time I notice that I have problems creating new users from the settings menu. I can create new users but not set their password. If I let the new users be without password I get kicked out whenever I try to log in with them.

Any ideas?

[EDIT]

Starting the shell (today) and asking for id I get

groups: cannot find name for group ID 1097972621
mikael@glasbult:~$ id
uid=1000(mikael)gid=1000(mikael),groups=1000(mikael),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),108(lpadmin),124(sambashare),1097972621

At the end out the output I notice a matching id: 1097972621

[NEW INFO]

Not sure if I should answer my own question or put it here. I mentioned the problem to my local sysadmin and he said the strange group number is an AFS-artefact. It's necessary for PAG, which gives a user the same rights in all sub-shell. Thus it's not an error, just an ugly nuisance.

Case closed I suppose.

  • 1
    Please add the output of id. – Jos May 9 '14 at 12:08
  • Mikael, I'd recommend answering the question, but adding as much info as possible. – conman253 Jul 24 '17 at 19:20
1

I have a similar issue on a machine I'm provisioning, but I don't yet know how to solve the problem directly, which in my case involves LDAP group enumeration.

However, /etc/bash.bashrc has a configurable flag to disable the section of bashrc that checks to see whether it should remind you how to use sudo. It is that section of bashrc that calls groups(1), which generates the error you are seeing.

To disable that check, and thus work around this error message, you can:

touch ~/.hushlogin
0

You can get rid of the message by commenting the following lines related to sudo hint in /etc/bash.bashrc:

# sudo hint
##if [ ! -e "$HOME/.sudo_as_admin_successful" ] && [ ! -e "$HOME/.hushlogin" ] ; then
##    case " $(groups) " in *\ admin\ *|*\ sudo\ *)
##    if [ -x /usr/bin/sudo ]; then
##      cat <<-EOF
##      To run a command as administrator (user "root"), use "sudo <command>".
##      See "man sudo_root" for details.
##
##      EOF
##    fi
##    esac
##fi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.