5

I would like to use CUDA on my Ubuntu machine with the graphics card NVIDIA Geforce 9600 GT. Installing CUDA is no problem but in order to run any CUDA code I need to install the proprietary NVIDIA driver as well.

I did so by choosing an appropriate one (for example, 331) from the list popping up in the "Additional drivers" menu. The installation works just fine but whenever I reboot the system all I see is a black screen with a blinking cursor.

After purging all NVIDIA related stuff (sudo apt-get remove --purge nvidia*), I'm able to use the system again after rebooting.

I read somewhere that this problem might be related to the fact that I have to use DVI instead of VGA as there are no other output ports on the card. However, switching from one DVI output port to another doesn't help either.

Any help is greatly appreciated.

  • This is a shot in the dark, but I used to have a similar issue with NVIDIA drivers for a 9800 and HDMI (instead of DVI). Installing the package nvidia-settings, which comes along with some drivers, solved the issue for me. If it breaks the display again you can always purge nvidia* as you did. – Alex May 9 '14 at 11:38
  • Thank you, Alex. Unfortunately, this didn't solve the issue. I managed to install nvidia-settings without problems but as soon as I install any proprietary drivers, I don't see much more than some status messages on the screen. – user279703 May 9 '14 at 17:48
0

I've found that manual installs work best for installing nvidia drivers, so go to here and download the latest drivers. By default, it'll most likely go into /Downloads, but if not, just know where it is. Then, you'll want to press

ctrl + alt +F1-F6 (each is a different login)

And then sign in to your account. Then, you'll want to use

sudo stop lightdm (or sudo service lightdm stop)

This shuts down the things that are using the GUI, so they can be updated.

Then run

chmod +x ~/* Folder that said driver is located in * / * Driver *

For example,

chmod +x ~/Downloads/NVIDIA-Linux-x86_64-343.13.run

Make SURE that you have the entire name of the driver, otherwise this will not work! Caps do matter!

What you just did was make the file executable. Next, you'll want to run the following command, changed of course like the example above to fit your directories/driver versions.

sudo sh ~/Downloads/NVIDIA-Linux-x86_64-343.13.run

For me, tabbing the rest of the NVIDIA-Linux-x86_64-343.13.run file does not work for me, but it is CRUCIAL THAT YOU DO THIS. If nothing happens after you run the second command, check your caps and spelling to make sure they are right. You have to go through the program using the keyboard to correctly install it. For me it will tell me that something went wrong right on the bat, just keep going and see if it still works. If it asks you to install 32 bit libraries, do so. Some programs (like steam games) will not run unless you have these installed.

After all of the above has been done, one final command must be completed, or of course you could reboot.

sudo start lightdm (or sudo service lightdm start)

Then, you'll do

ctrl + alt+ F7-F9ish (F7 is usually default, some people have different F keys though)

This should have worked for most people, if not keep looking, there's always a fix. If anyone knows something about getting virtual 7.1 audio to work, please message me somehow. Thanks. Hope I helped someone.

I've also heard x-swat repositories work better at times. Not sure about that, but worth a try.

(Pro tip, whenever Nvidia related stuff goes wrong, watch this.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.