5

I'm new to Linux world and I have a problem with my fresh installation of Ubuntu 14.10 64-bit. My processor is Intel® Pentium(R) D CPU 2.80GHz × 2 with 4 GB of ram and GeForce 8600 GT/PCIe/SSE2. When I use PC CPU load is always above 0.90.

I found these questions but no luck at all with finding solution:

In terminal top Xorg and Compiz are always first. For example while I'm moving Firefox window both go around 60% of CPU or when I open the search menu and typing random stuff.

In Unity Tweak Tool texture quality is on fast and all animations are disabled + blur under search windows is turned off, installing Unity 2D doesn't work.

I'm using the NVIDIA Binary Driver 331.38 and changing workspaces is very smooth just like scrolling pages is Firefox.

Also I disabled the hardware acceleration in Firefox and some of the plugins. I have right now turn on Adblock Plus and Flash - block.

I'm not sure but this can help:

sudo dmidecode -t processor | grep Speed
Max Speed: 4000 MHz
Current Speed: 2800 MHz

Also done this.

Copy and paste, or type, the following lines at the bottom of the Screen section:

Option "RenderAccel" "True"
Option "DisableGLXRootClipping" "True"
Option "DamageEvents" "True"
Option "UseEvents" "True"

Then I had to recover the Xorg default settings, when I restarted PC window show up with something like:

You are running low graphics mode

but I fixed it so all is OK right now.

It's 5th day and I'm stuck, so I'm begging for help.

Also I installed XFCE (Xubuntu 14.10) and LXDE (Lubuntu 14.10) but I like Unity much more.

On Ubuntu 14.10 32-bit is even worse + here is my top when PC on idle, all look good:

load average: 0.11, 0.21, 0.29

but PC is for work not idle.

So finally my question: is it normal? If not how can I fix my CPU usage? Why is Xorg and Compiz so resource hungry?

  • Current version is 14.04... Anyhow, I'd advise to install some light monitor, like conky (there are nice themes, BTW), to see permanently the CPU load and identify what is “eating” resources. Unity 2D is no longer available in 14.04. Maybe you should disable as well the dash “on-line search” and see how this improves behavior. – Ed Villegas May 8 '14 at 23:04
  • I have disabled on-line search and files search. It's more resposive right now so thanks. Also i installed :apps.ubuntu.com/cat/applications/precise/indicator-multiload – user279559 May 9 '14 at 20:50
  • Now i can see that most of the usage is because of Firefox. I'm worried i will have to upgrade my PC to use ubuntu. What do you think about Intel® Pentium(R) D CPU 2.80GHz ?? – user279559 May 9 '14 at 20:52
  • That CPU is not that fast, but I think is OK to run Ubuntu. Apart from a newer laptop, I also use a 5 year old Dell 1525 with a Pentium (R) @ 2.10 GHz (double core) with 2 GB RAM. It's not a thunderbolt but performs quite well. I have only disabled on-line search, because I really like the file search function. One note regarding “indicator-multiload”: under some systems this app has a memory leak. Otherwise it is an easy way to monitor resources. – Ed Villegas May 9 '14 at 23:33
  • 1
    With a Hyperthreading CPU like the Pentium D, A load average of 2.0 would equate to 100% usage. A dual core hyperthreading CPU like an i3 would have a load average of 4.0 at 100% usage. This may help you to more accurately assess load. I wouldn't worry too much about it, but if it disturbs you, upgrade to a faster CPU. – Elder Geek Aug 4 '14 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.