0

I've searched around and nothing seems to be up to date.

I installed Ubuntu 14.04 alongside Windows 7 on a Toshiba Satellite S50.

My WiFi detects the network, but keeps asking for a password and saying "You have been disconnected". My WiFi device is a RealTek RTL8188EE Wireless Network Adapter, for which none of the drivers I've downloaded have been able to compile on the newer kernel.

I tried plugging in a cheap USB WiFi dongle, and I was able to connect, however my connection seemed to drop out every few minutes and not come back until I reseated the WiFi dongle.

Any help is appreciated.

1

I had the same problem and fixed it using the command:

sudo iwconfig wlan0 rate 54M
  • You may want to add detail, such as what the command actually does (which I personally deem very important whenever giving commands involving elevated privileges). – s3lph Apr 14 '15 at 23:02
0

Try opening Ubuntu Software Center, navigate to "Edit > Software Sources > Additional Drivers" and see if the system can detect any additional drivers.

  • Only video card drivers showing up. – shenk May 12 '14 at 15:21
0

Thanks to praseodym over at ubuntu forums.

sudo apt-get install --reinstall linux-headers-generic linux-headers-$(uname -r)     
build-essential dkms git
git clone https://github.com/FreedomBen/rtl8188ce-linux-driver
cd rtl8188ce-linux-driver
make
sudo make install
sudo cp -r firmware/* /lib/firmware
echo "options rtl8188ee ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8188ee.conf

fixed the problem for me. Seems this person's repo had a branch updated for compiling on 14.04 and I was able to compile the firmware correctly this time.

Note: Had to run make twice as it ran into a directory not found problem for a directory it was creating.

Source: http://ubuntuforums.org/showthread.php?t=2219952

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.