I have installed gMTP and tried to follow this tutorial to solve this problem: http://www.webupd8.org/2013/01/upgrade-to-gvfs-with-mtp-support-in.html

But neither worked. I tried to connect both my phone (Nexus 4) and my dad's phone (Galaxy Note 2), and neither is being detected by Ubuntu. They don't show up on my files and on gMTP.

Is there another fix? or something more specific for Android 4.3 and Ubuntu 14.04


3 Answers 3


I had the same problem this fixed it:

sudo apt-get install mtpfs

Once that's installed, plug in the phone to your computer. If nothing happens, on the phone go to Settings > Storage > Upper Right Corner () > USB Computer Connection > Media Device.


Settings > Search (type in "usb") > USB configuration ... If non existent make sure developer options have been enabled.

Open Settings> About> Software Information> More.
Then tap “Build number” seven times to enable Developer options. ...
Go back to Settings menu and now you'll be able to see “Developer options” there.
Tap it and turn on USB Debugging from the menu on the next screen.

Once they have been enable and the above package installed, also be sure to have the phone plugged in and then go back into developer options and update the USB configuration as shown in the picture below.

enter image description here

  • 26
    That didnt work...
    – asosnovsky
    May 12, 2014 at 23:50
  • 5
    Yea this finally worked out lol It didn;t work originally because my phone didn't has mtpfs enabled facepalm
    – asosnovsky
    Jun 13, 2014 at 23:47
  • 7
    I already had mtpfs installed but the phone would not mount. I plugged the phone into a different USB port and it worked...not sure why.
    – Jerinaw
    Feb 25, 2015 at 1:31
  • 1
    Something buggy about this. I too plugged in a different USP port and it worked.
    – Donato
    Apr 30, 2015 at 4:31
  • 1
    In fact, sometimes you even have to restart the phone.
    – Donato
    Jun 2, 2015 at 3:30

I use Android 7, Ubuntu 16.04.

My phone did not connect via USB. Only blank Nautilus window opened. Installing mtpfs did not help. Phone was mounted, hovering the mouse over "Samsung Android" field in Nautilus showed "mtp://[USB 001, 014]/". Press eject did not change the condition. Pressing alert dialogue in phone to allow computer access just opened another blank Nautilus window. In Android 7 I can no longer find developer options or how to set phone as media device.

I gave the following commands in the terminal:

  1. sudo apt-get install jmtpfs
  2. sudo mkdir /media/myphone

After doing this, the phone connected without problems. I am not sure the second step is needed. Further steps (if someone may need them) can be found here: How to connect Android 7.1 to Ubuntu Linux with USB?

When I now connect the phone, Nautilus will still open with a blank window, but after pressing the alert box "Allow computer access" (that appears in the phone), a second window opens in Nautilus, showing both phone memory and external card.


With the phone (Android 6) plugged in via USB Nautilus (Ubuntu 16.04) shows "USB Driver". Clicking the eject icon in the name removes this label from Nautilus and a moment later the smart phone is mounted with internal storage and SD card opened in the window.

  • Installed mtpfs. I press eject but Nautilus window still opens blank when phone is connected. I confirm one alert box in phone to allow computer access, that will just open another blank Nautilus window. I can not find developer options or how to set phone as media device in Android 7. Use 16.04. Any advice appreciated.
    – cvr
    Aug 1, 2017 at 18:53
  • If I hover mouse over "Samsung Android" field in Nautilus it shows mtp://[USB 001, 014]/ I assume it means the phone is mounted. Nautilus also opens new window when I confirm computer access in the phone. But still blank Nautilus windows.
    – cvr
    Aug 1, 2017 at 19:01
  • My problem is solved, using this: askubuntu.com/questions/854332/…
    – cvr
    Aug 1, 2017 at 19:12
  • @ycc_swe Thank you for sharing your journey. You might want to write an answer of your own and post it here. My answer here was one of the first ones I had written and now I deem it to be low quality. As such I will be deleting it soon. Aug 2, 2017 at 0:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.