1

I've tried using Alcatel's One Touch 4G USB modem on a newly installed Ubuntu 14.04, but with no luck. The carrier is Portugal's Optimus Kanguru.

Following suggestions online, I've installed usb-modeswitch, usb-modeswitch-data, wvdial and comgt.

When I plug it in, NetworkManager's applet adds the option to enable Mobile Broadband. I enable it, but when I try to create a new connection, the combo box has no devices in it. Only the "Any device" option. I set it up anyway with a multitude of all possible APN's I could find (incl. none) but when I try to connect, it immediately fails.

Following instructions online, I've also attempted to connect with wvdial, by running:

sudo wvdialconf
sudo wvdial

with the following result:

Sending: ATDT*99#
Waiting for carrier.
Timed out while dialing. Trying again.
Sending: ATDT*99#
Waiting for carrier.
Timed out while dialing. Trying again.

(and so on...)

I also tried using different APNs in /etc/wvdial.conf to no avail.

lsusb shows the device as:

Bus 001 Device 010: ID 1bbb:011e T & A Mobile Phones

usb-devices shows this:

T:  Bus=02 Lev=02 Prnt=02 Port=01 Cnt=01 Dev#=  9 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1bbb ProdID=011e Rev=00.00
S:  Manufacturer=USBModem
S:  Product=Mobile Broad Band
C:  #Ifs= 5 Cfg#= 1 Atr=e0 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
I:  If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 4 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=qmi_wwan
| improve this question | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.