2

I have a laptop with Windows and Ubuntu. There were some bad sectors in a partition used by both Ubuntu and Windows. I have run chkdsk (from Windows installation disk), and so Windows will not access these bad sectors anymore.

However, will Ubuntu try to read/write to these sectors causing further errors?

1

I think the true answer is it depends.

Have you tried running any hardware testing software outside of windows or Ubuntu? This will help you determine if the bad sectors are hard or soft bad sectors.
-If they are "soft" bad sectors, chkdsk has already repaired them and both windows and Ubuntu will both write to those portions of the disk again.
-If they are "hard" bad sectors, you must start asking yourself things like...how old is my disk? have I caused any damage to the disk (like drops or falls)? If not, then there may be something wrong with the S.M.A.R.T controller on your disk. This piece of hardware is supposed to take care of marking bad sectors so that NO operating system running on the disk writes or reads to those areas.

-Preferably before but you can after; you perform your hardware test outside of all operating systems using a utility like pc-check you should make a backup just in case your drive is on the verge of failure. Hope this points you in the right direction.

3
  • Thank you. Indeed, I dropped my laptop and so there are these bad sectors.
    – Huynh
    May 8 '14 at 8:01
  • @Huynh Be careful I had an incident with my cat where my laptop went flying off the table because his tail caught my power cord to the laptop. Worked fine for a few days...then boom everything was gone :( Now I use only SSDs and power cords are hidden from all cats...haha
    – user175999
    May 8 '14 at 8:08
  • chkdsk doesn't try to repair bad sectors; it just foolishly flags them as not to be used.
    – psusi
    May 8 '14 at 13:47
0

If you have installed ntfs-3g,ntfs-config,ntfsprogs, testdisk packages then fsck can help you to fix those bad sectors with

fsck /dev/sdaXX

XX nothing but drive number of the windows/NTFS.

If you have not installed them then install them with

sudo apt-get install <package_name>
4
  • > So I have to check again inside Ubuntu?
    – Huynh
    May 8 '14 at 7:57
  • > I have ntfs-3g, ntfs-config and testdisk installed, but I could not install ntfsprogs; as I ran apt-get, it returns a messages: "E: Package 'ntfsprogs' has no installation candidate"
    – Huynh
    May 8 '14 at 8:00
  • @Huynh for comment 1: to directly check in Ubuntu , I am giving this. for comment 2: in terminal type as apt-cache search mtfsprogs
    – rɑːdʒɑ
    May 8 '14 at 8:13
  • @raaz I am having the same trouble finding ntfsprogs is there a repo or ppa I need to add?
    – user175999
    May 8 '14 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.