3

I recently upgraded to Ubuntu 14.04 (using Update Manager), and it works fine with no issues.

In which I am using SQL Developer 3.2.20.09 and it works fine. Now a newer version was released on May 5th 2014, and I would like to use it, as it works fine with JDK 1.7. I followed the installation instructions provided by Oracle, but it fails to install.

  1. Downloaded sqldeveloper-4.0.2.15.21-1.noarch.rpm from http://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/index.html

  2. Followed installation instructions from http://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/sqldev-install-linux-1969676.html using the command:

    rpm -Uhv sqldeveloper-4.0.2.15.21-1.noarch.rpm  
    

    which resulted in:

    rpm: RPM should not be used directly install RPM packages, use Alien instead!
    rpm: However assuming you know what you are doing...
    error: Failed dependencies:
        /bin/sh is needed by sqldeveloper-4.0.1.14.48-1.noarch
    
  3. Used Alien to install the RPM package:

    sudo alien sqldeveloper-4.0.1.14.48-1.noarch.rpm 
    

    which resulted in this error:

    error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
    error: cannot open Packages index using db5 -  (-30969)
    error: cannot open Packages database in /home/arthanarisamy/.rpmdb
    

Should any package be updated manually, or have I missed updating while upgrading to Ubuntu 14.04?

4
  • Is there a specific reason why you are using the RPM instead of the "other platforms" I use SQL Developer but I have always installed it using this method. www.oracle.com/technetwork/developer-tools/sql-developer/downloads/otherplatform-installnotes-1719935.html
    – levlaz
    May 8 '14 at 5:06
  • No, there is no specific reason for using it, i tried to download Linux version and its installation notes.
    – Samy
    May 8 '14 at 5:10
  • Also i can give a try with other platforms as well, will let you know in some time about it.
    – Samy
    May 8 '14 at 5:11
  • 1
    Using other platform downloads and zip file worked, but had to modify sqldeveloper.sh file as below #!/bin/bash unset -v GNOME_DESKTOP_SESSION_ID cd "dirname $0"/sqldeveloper/bin && bash sqldeveloper $*
    – Samy
    May 8 '14 at 6:30
2

You should first convert .rpm file to .deb which is the installation file format in ubuntu.

sudo alien -d sqldeveloper-4.0.2.15.21-1.noarch.rpm

Then install that .deb file by :

sudo dpkg -i sqldeveloper-4.0.2.15.21-1.noarch.deb
2
  • Thanks. Will try this solution and update. I was missing -d while executing alien command.
    – Samy
    May 8 '14 at 6:31
  • sudo alien -k --scripts sqldeveloper-4.0.2.15.21-1.noarch.rpm works too
    – catch23
    Jul 17 '14 at 17:46
1

I don't like using converted RPM for installation in Ubuntu, if there is an alternative.

I prefer manually using a binary package, specially with Java applications that usually does not have specific dependency (obviously JRE / JDK).

In this case, I install SQLDeveloper in this way:

  • download the "Other Platforms" package: sqldeveloper-4.0.2.15.21-no-jre.zip
  • unzip the package in /opt/sqldeveloper (or other directory if you like, I put all manually installed packages in /opt)
  • create a sqldeveloper.desktop file in /usr/share/applications (for all users) or ~/.local/share/applications (for your user only)
1
  • 1
    Please make a link for sqldeveloper-4.0.2.15.21-no-jre.zip Jun 24 '14 at 6:32
0

For me while rpm was not installed when I double click on the document it extracts it and I was able to run sqldeveloper by running /opt/sqldeveloper/sqldeveloper.sh bash file

-1

The error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch error happens the first time you run rpm (or alien) on Ubuntu.

Create the RPM DB with:

sudo rpm --rebuilddb

to get rid of it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.