3

After fresh install of Lubuntu 14.04 no sound card is detected. Alsamixer shows just Beep bar (PC speaker), all inputs and outputs are just not present. No volume panel in the main bar was present.

What I did try:

  • Google hard for any solution without major sucess
  • installation of some libraries (pulseaudio) - it adds just the Nvidia HDMI output and volume panel, but not the soundcard's output
  • inserting options snd-hda-intel model=generic or model=auto into /etc/modprobe.d/alsa-base.conf and restart
  • inserting options snd-hda-intel position_fix=1 model=medion into /etc/modprobe.d/alsa-base.conf and restart with
  • inserting options snd-hda-intel model=fujitsu into /etc/modprobe.d/alsa-base.conf and restart

Windows sound goes OK after correct driver is present.

dmesg |grep -i snd_hda shows (after modprobe is edited) 2 lines showing the profile for MSI/MSI-X is used on IRQ 45 and 47

Alsamixer identifies card as HDA Intel and chip as realtek ALC880

Google shows just problematic results from ubuntu 8.10 version.

It is an old Fujitsu-siemens mainboard with Pentium D and integrated sound card. next solution would be to insert an old PCI sound card into it... -d:C(

Does someone has a success with it?

Update: after bounty without answer, many attempts to solve this issue I added a simple sound card into PCI slot and everything works with no problem. This realtek on-board chipset I canot recommend with Ubuntu. :c\

  • what options have you tried for the sudo modprobe snd_hda_intel model=xxxx command - various people have had success with either 3stack or 6stack - what changes do you observe if you use this instead of fujitsu ? – fossfreedom May 13 '14 at 7:25
  • Did you try sudo apt-get remove --purge alsa-base pulseaudio then sudo apt-get install alsa-base pulseaudio and finally sudo alsa force-reload? – TuKsn May 19 '14 at 10:17
  • I did try removing and force reload Alsa before, no result – Dee Jun 1 '14 at 3:31
  • @fossfreedom: no changes whatever parameter i choosed. 3 or 6 stack differs just with mapping of in-outs. I have always just a PC buzzer in alsa – Dee Jun 1 '14 at 3:33
3

I don't have an 880, but this might work. You can download the driver from the RealTek site and compile it yourself.

RealTek Driver Page, Pick the 3.0 driver The Rest of this is taken from here and posted to askubuntu.

  1. Open terminal.

  2. Type: "sudo su" and enter root password.

  3. Change to the folder where you downloaded the driver (ie: "cd ~/Downloads")

  4. Type: "tar -xjf LinuxPkg_XXX.tar.bz2" , where XXX is the version of your downloaded driver (as sown in filename, example: "tar -xjf LinuxPkg_5.17rc13.tar.bz2").

  5. Type: "cd realtek-linux-audiopack-YYY" , where YYY is the version of your downloaded driver (as shown if folder name, example: "cd realtek-linux-audiopack-5.17").

  6. Type "tar -xjf alsa-driver-ZZZ.tar.bz2" , where ZZZ is the version corresponding to the filename (example: "tar -xjf alsa-driver-1.0.25-5.17rc13.tar.bz2").

  7. Type "cd alsa-driver-WWW" , where WWW is the version corresponding to the folder name (example: "cd alsa-driver-1.0.25").

  8. Type "./configure --with-cards=hda-intel"

  9. Type "make"

  10. Type "make install"

  11. Reboot

  12. Test the audio output. You can do this by right-clicking on you speaker icon and selecting sound preferences -> hardware -> select the desired audio output -> select the desired surround profile (ie: Analog Surround 5.1 Output + Analog Stereo Input) -> Test Speakers. During the installation the sound level can be mutted, check out in the slider if it is not mute!

  • The odds of this working are very good. – Elder Geek May 19 '14 at 17:01
  • This loooked very promising, and there is a change afterwards. In Alsamixer, there is a PCM output on Intel HDA soundcard. But in mixer, there is no sound device in exception of HDMI videocard sound ability. :C( – Dee Jun 1 '14 at 4:07
  • 2
    Drivers "Rt-Linux-HDaudio-5.18" crashed with errors on compilation with kernel 4.2. – Max Vyaznikov Oct 30 '15 at 21:59
  • Yes make throws errors – Hack-R Nov 27 '16 at 0:38
1

No idea whether this will help you, but I know the frustration of running out of ideas, so if you don't get any other leads, perhaps worth a try.

I have an Asus laptop on which I recently installed Lubuntu 14.04. I wasn't getting any sound from the laptop's main internal speakers with the default installation.

I ended up installing pavucontrol (otherwise known as PulseAudio Volume Control) package. (PulseAudio itself was already installed.) Within pavucontrol, under the Configuration tab, there were two Built-In Audio device profiles listed. The top one was "Digital Stereo (HDMI) Output (unplugged)". The bottom one was "Analog Stereo Duplex". I changed that bottom "Analog Stereo Duplex" to "Analog Stereo Output". That change gave me sound output through the laptop's internal speakers. (I had gone through a similar experience with Lubuntu 13.10.)

  • Thanx but it is not applicable, no Asus notebook here, just an old PentiumD desktop Mboard. Only HDMI I have is from Graphics card, so I can theoretically get audio, but not trough sound card stereo jack. there is nothing under or above to change on it... other outputs are just NOT present. – Dee Jun 1 '14 at 3:43
1

"./configure --with-cards=hda-intel"

"make"

"make install"

  • these ran without error, but when I rebooted there was still no sound. After a spot of gooogling , and more in desperation than expectation, I installed pulseaudio and pulseaudio-utils.

My laptop then refused to boot! but after a lot of fiddling around taking out the battery etc it booted up and, much to my surprise, there was a speaker icon and sound.

Thanks again.

  • please don't double post for a question. you can edit and or improve your previous answer instead. thanks – αғsнιη Sep 26 '14 at 11:08
  • he cant edit, his score is (1). Good would be to know what kind of fiddling you did. Unfortunatelly my card is ALC880, so it is not sure it will work in my case. – Dee Sep 28 '14 at 9:33
0

Lubuntu 14.04. Ergo Z91F Dual Core laptop, alc660 soundcard.

I followed Scott Goodgames advice and it worked for me eventually. (Thanks, Scott)

I hope this rundown will help those who, like me, struggle with command-line stuff.

I downloaded the driver into a folder named "alc660". For some reason the "tar" instruction wouldn't work for me, but opening with Xarchiver worked.

This produced a folder named "Rt-Linux-HDaudio-5.18". In this folder was another tarball named "alsa-driver-RTv5.18rc8.tar.bz2" ( plus a guide and a Readme) I "Xarchiver"ed this tarball and got the folder "alsa-driver-RTv5.18".

When I tried to run "configure" I kept getting "no such file or directory". This was because I was "CD"ing to the wrong place: the "configure" script is in another folder (underneath "alsa-driver-RTv5.18" named "alsa") so I needed to CD to /home/geoff/alc660/Rt-Linux-HDaudio-5.18/alsa-driver-RTv5.18/alsa

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.