29

In Ubuntu 12.04~13.10, the Settings >> Display >> Sticky Edges [On/Off] option was available. In Ubuntu 14.10, it is missing. How do I disable Mouse Edge Stickiness so that when I move my mouse from the left monitor to the right monitor, it doesn’t STICK to the edge, in Ubuntu 14.04?*

As suggested below, I tried using unity-tweak-tool, but could not locate the Mouse Edge Stickiness option. Any guidance is appreciated.

Once again, Thank you, as this will help my carpal tunnel syndrome! Thank you!

11 Answers 11

28

Go to Displays and disable Sticky edges.

screenshot

  • 18
    This doesn't work. I have it set to "off" and it still "sticks" on the edge between my monitors. It's infuriating. – Cerin Apr 29 '15 at 18:47
  • Kellen's answer below worked. I already use CCSM so it was easy to adjust the edge stop velocity to a lower setting. – Brenden Aug 7 '15 at 19:59
  • Doesn't work. I have switch OFF, but edges are still sticky – Green Feb 9 '18 at 6:52
14

Did you install Unity with the CompizConfig Settings Manager? You can download it with sudo apt-get install compizconfig-settings-manager. Then launch with ccsm. Click the desktop section on the left then Unity plugin, use the filter to find "Edge Stop Velocity" and set it to 0.

  • This worked on Ubuntu 15.10 (Wily). – Dean Rather Apr 14 '16 at 0:58
  • 3
    Works on Ubuntu 16.04. The accepted answer doesn't. – ComputerScientist Dec 12 '17 at 23:33
  • Thanks. Sticky edges were turned off but one day it started sticking even though the option was off. This resolved the problem. – rjh Apr 24 '18 at 15:52
7

I fixed it in 14.04 with compizconfig-settings-manager as Kellen Donohue mentioned.

By setting "Edge Stop Velocity" to 1 (0 isn't accepted) and "Duration of Sticky Edge Relase after Break" to 0.

I needed to logout/login again.

  • On Vivid it worked instantly without the need to log out. – ccpizza Dec 26 '15 at 21:49
  • it works on 16.04 – thenaglecode Mar 8 '17 at 23:42
3

DON'T confuse this with the "Snapping Windows" setting, which can be set via "CompizConfig Settings Manager", which is downloadable from the Ubuntu Software Centre. Also works on 15.10

  • So in CompizConfig its "Windows Management" >> "Snapping Windows", UNCHECK. To get deeper you may click the hover button (that magically appears). Then you'll have access to even more granular window snapping settings. – MannyC Jan 29 '16 at 15:07
2

For those that googled this answer looking for how to disable Window sticky edges. Type ccsm (to install sudo apt-get install compizconfig-settings-manager) and filter by edge. Go to Snapping Windows > Behavior > Snap Type and uncheck Edge resistance and Edge attraction.

  • 1
    Edge resistance gets checked again a second after unchecking it for me. – jozxyqk Dec 11 '18 at 1:55
1

I did this with the unity tweak tool, it has a gui so its easy to use. its available in ubuntu-software-center

  • I did sudo apt-get install -y unity-tweak-tool; unity-tweak-tool; >> And looked through all of the options but I could not find out where to disable Mouse Edge Stickiness. Can you please tell me where? – Bran May 8 '14 at 4:00
  • 1
    Windows, There should be a picture of your desktop and a bunch of options all around with colored corners. The colored corners/ edges represent your hot spots for the sticky edges. There are bars on the side of each hotspot to select the prefered action, there should be "do nothing" as an option – Deim May 9 '14 at 13:48
  • Window Manager -> Window Snapping – Matthew Read May 27 '15 at 18:35
  • "It has a gui so it's easy to use". I would draw the exact opposite conclusion from something having a gui. I'd much rather copy and paste a single command or a series of commands, which would fix everything, instead of having to navigate through a maze of options in a gui. – Joeytje50 Aug 2 '17 at 19:42
  • Transitioning to Ubuntu from Windows makes you realise how smooth some of the Windows GUI controls/defaults are. – WillC Oct 17 '17 at 4:58
1

It's because of the menu. ntrrgc is right, but you have to put the launcher bar all to the right, not in each display.

That fixes the stick problem and is worse, when you have that menu in both displays and with the option hide menu bar.

1

The best answer is here: How do I disable mouse magnet on middle edge with multi monitors?

You need to change "Launcher Placement". Change "All Displays" and only select your left-most display. MAGIC!

0

CompizConfig -> Window Management -> Resize Window -> General Uncheck Maximize Vertically if screen edge hit

Compbiz Check setting -- screen edge

0

I tried others' CompizConfig settings for edge stop velocity, overcome pressure, duration of sticky edge release, etc. to no avail.

I ended up unchecking "Launcher Capture Mouse" in the same settings screen and it's working as I hoped it would: no stick whatsoever.

This is on 16.04 btw

-1

One solution is to set the external monitor onto the left side of the desktop monitor in System-Settings >> Displays. This changes the direction you slide your mouse into the next screen, but this works when the "Sticky Edge" and CompizConfig-System-Manager options do not.

Drag and drop external monitor to the left side of the main monitor

-Please rep if this helps you -- I need 10 reps to post images!! D=

It appears that the issue with the right side is the placement of the workspace navigator along the right edge of the main monitor. The workaround is to find the sweet spots above and below the navigator but that can be rather annoying to rely upon.

NOTE: Applying this change to the left side of the monitor relinquishes any left-screen edge mouse controls such as the system search bar and the applications sidebar. However you still can access it via the "Super" button. But if you're using Gnome-Do or if you're a terminal wiz, this shouldn't be much of an issue..

  • Doesn't work in Displays – Green Feb 9 '18 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.