12

Have Ubuntu 14.04 installed on a Toshiba Satellite S50 with Windows 7. Offnote: Was experiencing freezes with the proprietary nvidia driver so I switched to the Nouveau driver.

My ubuntu will not shut down or reboot. I try typing

sudo reboot -h -q now

among other variations as well as shutdown but I get other outcomes:

  1. It closes x and freezes at the terminal with a _

  2. It closes x and I get a terminal:

    wait-for-state stop/waiting
    * Stopping rsync daemon rsync
    saned disabled; edit /etc/default/saned
    * speech-dispacher disabled; edit /etc/default/speech-dispacher
    Stopping SpamAssassin Mail Filter Daemon: No /usr/bin/perl found running; none killed.
    spamd.
    ModemManager[828]: <info> ModemManager is shut down
    ModemManager[828]: <info> ModemManager (version 1.0.0) is starting...
    ModemManager[828]: <warn> Could not acquire the 'org.freedesktop.ModemManager1' service name
    ModemManager[828]: <info> ModemManager is shut down
    ModemManager[828]: <info> ModemManager (version 1.0.0) is starting...
    ModemManager[828]: <warn> Could not acquire the 'org.freedesktop.ModemManager1' service name
    ModemManager[828]: <info> ModemManager is shut down
    * Killing all remaining processes...
    * Will now switch to single-user mode
    

    root@laptop:~#

And I get a root prompt.

Side Notes: Using Gnome Desktop, lightdm

Why am I unable to shutdown or reboot?

2
  • 1
    Have you tried using ´sudo shutdown -h now´ and ´sudo shutdown -r 0´ (from another thread: superuser.com/questions/360544/…)
    – Xweque
    May 7 '14 at 21:31
  • I experience the same in a VirtualBox machine. The only thing I did was install Ubuntu, then "sudo init 0". Mar 12 '17 at 12:03
5

For others with this problem, I was experiencing the same thing. I didn't even have to try this (which was my "okay, i'll deal with it this way" option).

After a Google search I found another solution, which is to go into /usr/share/dbus-1/system-services and rename the file org.freedesktop.ModemManager1.service to anything else. I called mine thisfilebreaksmycomputer.service. I had to sudo the mv command to do this.

Upon renaming I was able to successfully shut down and boot up without any issues!

3
  • Didn't work for me.
    – lepe
    Nov 29 '14 at 3:42
  • Trying it. At work, so it may take a while before I reboot.... Dec 18 '14 at 17:09
  • also didnt work in Ubuntu 14.04 Apr 22 '16 at 10:20
5

Confirmed to be a bug: https://bugs.launchpad.net/ubuntu/+source/upstart/+bug/1174272 The solution using sudo shutdown -r 0 to reboot, and sudo shutdown -h now to shut down, worked around it. It seems to be getting some attention now.

4
  • How about using sudo init 0 to shutdown and sudo init 6 to restart? Jul 24 '14 at 16:15
  • I get this message when I use "Shutdown" from the GUI--it appears in the top right of the screen without a shell prompt. In this case, where I can't type sudo shutdown, what should I do?
    – Arthur
    Feb 9 '16 at 12:52
  • 1
    sudo shutdown -r 0 to reboot did not work in 14.04 for me Apr 22 '16 at 10:20
  • none of the proposed solutions worked
    – John C
    Feb 21 '17 at 11:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.