1

The button in Software Center→Edit→Software sources... is disabled.

Is there another way to reach it or simple enable the button? What could be causing it?

If I know I can fix it myself and avoid happening again. Thanks!

1

I figured everything out.

For some reason, my System Settings process was called gnome-control-center. Since it seemed buggy, I removed it:

sudo apt-get remove --purge gnome-control-center

... expecting to then reinstall it to see if it would behave better.

After the uninstall I tried to access it from the top right system button and guess what... It DID show up with all the configuration buttons!

I have two guesses:

  1. The distro upgrader changed the System Settings program but didn't update the name entry for the menu, because the package was there the whole time;

OR

  1. At some forgotten point I installed gnome packages and screwed up Ubuntu's evolution. Then the distro upgrader didn't recognize it or or opted out to leave my choice of using a gnome tool instead of, maybe, "unity control center"?

Anyway. There is the info for anyone crossing this issue. I have seen other people in the same situation around the web. I hope this helps someone.


Editor's Addition (by Anwar)

It's the installation of gnome packages and not removing them cleanly. gnome-control-center is GNOME3 sessions part and not meant to be used in Unity.

  • 1
    It's the second one. gnome-control-center is a gnome3 part, unity-control-center is the Unity component. – Anwar Nov 2 '16 at 13:36
0

In Kubuntu 14.04 use Muon Discover. Just type muon discover in the search field of Kmenu or go to

**Kmenu > applications > system > software center (Muon discover) [with blue icon].

In muon discover choose the "sources" tab at the top of the window. Then click on configure software sources in the top right corner, enter your password, and enjoy!

0

Is there another way to reach it ... ?

I think you can directly access it through Software & Updates either from the dashboard or from the System Settings panel (in the shutdown button).

Now for the second part of the problem:

Try reinstalling ubuntu-desktop as proposed here

  • Thanks for your reply, Raph. Actually, I don't know if it was there before, but... – Chiur May 8 '14 at 12:39
  • Damn! After searching for over an hour. I just realized that the software sources needed to be manually reinstalled after the upgrade from 13.10. It can be installed from the Software Center. The package is called "software-properties-gtk" or "software-properties-kde", if you want to install it from the command line. Now that was really weird. I guess it is not installed by default because it is technical application and occupies 260MB in the hard drive. – Chiur May 8 '14 at 12:40
  • In my opinion, given that I upgraded from a system that had it, it should keep having it! If I was going for a fresh install, I'd like to have a check box like this: "[ ] install basic technical tools?". Or something like that, because it is actual infra-structure. It could go in the same step where you check a box for Flash. I won't bother reporting directly to Canonical, because they must have realized this confusion already. Cheers! – Chiur May 8 '14 at 12:41
  • Oh! And I had already completely removed ubuntu-desktop and and reinstalled it. It was my first trial, by the way. Wipe everything away and replace... sounds like the perfect idea :D See my replies to my own question. The problem was a bit more obscure. Thank you very much for your time and experience :) – Chiur May 8 '14 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.