1

I installed Trusty on my laptop. I like Gnome Shell more than Unity.

So I installed Gnome Shell via Software Centre.

I have LightDM 1.10.0 installed on my system. Unlike the previous version it does not help me to switch and view all the installed desktop sessions in my system.

So I am unable to switch to any other session.

I then switched to gdm. gdm only shows two options 1. Ubuntu 2. System Default.

System Default option does not load any desktop environment and stuck on a empty wallpaper. But I could do it via command line to load gnome-shell (gnome-shell --replace).

  • What is the way to enable lightdm to give option to switch to different sessions other than Unity?
  • Why does not gdm include Gnome session along with Ubuntu and System Default?
  • 3
    try reinstalling gnome-session sudo apt-get install --reinstall gnome-session – user.dz May 7 '14 at 18:31
  • Sneetsher has the right idea, see my answer here for an explanation: askubuntu.com/a/452425/68188 – Jason Conti May 7 '14 at 18:41
  • Installing the gnome-session did not fix the issue completly but ligthdm and gdm got the Gnome session available. I then tried installing ubuntu-gnome-desktop for possible missing packages. Now the gnome-shell loads with accessibility Zoom enabled but on interacting it crashes and reload just for twice. After that only wallpaper is seen. – Shoaib Nawaz May 9 '14 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.