This question already has an answer here:

I am getting an error when I try to access my NTFS drive from ubuntu.

Unable to access “My Drive”

Error mounting /dev/sda6 at /media/ubuntu/Media Center: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda6" "/media/rolindroy/Media Center"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda6': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option

Any help would be greatly appreciated!

marked as duplicate by muru, Mitch Feb 20 '15 at 12:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I had this problem. It was because windows, being windows, decided to restart without asking me. When it restarts, it boots back up into linux. At that point, the drive was expecting to be restarted into windows and threw this error. – Marcel Feb 1 '16 at 2:32
  • Related: askubuntu.com/questions/462381/… – Nav Oct 20 '16 at 13:13

If you can't access the drive, execute the following command:

sudo ntfsfix /dev/sdXY

where XY is the partition

e.g sda2 or sdb1

Then, mount with:

sudo mount -o rw /dev/sdXY
  • 8
    This is the best solution if you can risk crashing of Windows. But for partitions other than the one on which Windows is installed, this is harmless, I think. – Devesh Khandelwal Feb 2 '15 at 17:33
  • 1
    It doesn't crash windows, not for me at least. On the far side, yes that may be a risk. – Muddassir Nazir Apr 6 '15 at 8:51
  • 1
    This error usually comes when Windows doesn't shutdown properly and you boot into Linux. – Muddassir Nazir Oct 25 '15 at 9:44
  • I try it but return Windows is hibernated, refused to mount. Remount failed: Operation not permitted – Yusef Mohamadi Dec 7 '15 at 21:29
  • 1
    @zhilevan I think you have to log into windows and shut down completely. Dont restart or hibernate. – Marcel Feb 7 '16 at 18:57

I solved the problem with shutdown Windows by cmd

shutdown /s

This is because Windows 8 and 10 offer a "Fast Startup" option that depends on a "non-complete" shutdown

You can disable fast startup by following these steps under "Power Options"

https://itsfoss.com/solve-ntfs-mount-problem-ubuntu-windows-8-dual-boot/

  • 4
    For this solution, you will have to first shutdown your Linux and then boot back into Windows and then do this thing, and then again boot back into Linux. – Muddassir Nazir Oct 25 '15 at 9:45
  • 1
    Thanks! This worked for me. I wonder why this made a difference as opposed to a regular shutdown from Start --> Shutdown on Windows? – Jon Oct 17 '16 at 21:22
  • 4
    @Jon: It's because shutdown /s performs a conventional shutdown. The shutdown via the GUI performs a fast shutdown for Windows 8 & 10, where it does something that's pretty much like a hibernation, so that startup and shutdown are fast. askubuntu.com/questions/462381/… – Nav Oct 20 '16 at 13:15
  • 1
    Thanks.. This worked for me.. But why on earth windows doesn't shut down properly ? Do I have to do this every time I switch between Windows and ubuntu ? – Hirak Nov 23 '16 at 12:32
  • 1
    Thank you for saving my sanity. – Chahk Nov 7 at 16:04

If you have access to booting and mounting the drive under Windows, do as the message indicates and remove it from the hibernation or fast restarting, or any other special state. You would have to do those things by booting into Windows.

You may also run chkdsk on it from Windows.

If you don't have immediate boot access under Windows for the drive, do as the message says and mount it as read only.

Then access the drive and copy the important data. You can then repair the drive under Ubuntu by reformatting the partition and bring the backed up data back.

Mounting drive as read only:

$ sudo mount -o ro /dev/[partition /media/[mounting point]

Another option is to repair the disk under Ubuntu with ntfsfix:

$ ntfsfix /dev/[partition]

This is because your "Windows" system is in a intermediate state, may be its in hibernation mode or not full shutdown, try a system restart on your windows and shutdown the system fully and check the mount on your Ubuntu, it should work.

Log on to windows and then restart to Ubuntu. Works for me! But seriously I don't know whether there is a permanent solution to that.

  • You are right!!!But we have customized solution to solve it permanently until the Windows encounters crash. – Wolverine Dec 28 '14 at 21:06
  • yea and from the other answers from here I am sure that there is more permanent way to fix it. I am not a geek so a general wusiwug method will be more appreciated by me. – ganezdragon Dec 29 '14 at 3:28

This should be because your "Windows" system is in a intermediate state (not a full shutdown of system before powering off the hard drive, like using hibernation for example).

Restart on Windows, shutdown down system fully and it should work.

If you try this on a command line term session, you should have this kind of explanation

Do:

sudo mount -o ro /dev/[partition /media/[mounting point]

The output will be:

The NTFS partition is in an unsafe state. 
Please resume and shutdown Windows fully (no hibernation or fast restarting), 
or mount the volume read-only with the `ro` mount option.

Not the answer you're looking for? Browse other questions tagged or ask your own question.