8

Xubuntu 14.04. After wake up from sleep, it asks to enter password. I entered the passw. and screen goes black. On Ubuntu 14.04 waking up was just ok. Lenovo E330 laptop with intel HD graphics.
add: If lid was closed, not clicked sleep

2
3

This is all great and fine. But for a noob or anyone who is not accustomed to CLI it doesn't make the problem any less bothersome. Here is the solution that worked for me.

  • Completely remove Light Locker using Synaptic Package Manager
  • Install Gnome Screensaver from the Ubuntu Software Center
  • Restart the computer
1
  • This works for me.
    – lovetl2002
    Oct 12 '19 at 1:55
2

Strangely, one day when I fresh installed Xubuntu, that problem stopped. Still, if this happen, try using the following tip:

  1. Get into the command line using Ctrl+Alt+F1.

  2. Put your credentials user/password.

  3. Write the following:

    sudo service lightdm restart
    

So it will take you back to the login screen.

Hope that helps! (It's not a fix for this problem, though. I had to get used to click the Suspend button instead of closing the lid.)

5
  • 1
    Doesn't Xubuntu use xdm as its default display manager instead of lightdm? Mar 26 '15 at 3:04
  • I can't give a full certain answer about it, but as a solution for that problem, it worked that way. I made that supposition because of how my given solution has worked for me, but I will edit it. Mar 26 '15 at 14:29
  • Problem with this, you need root access. I have to bug my boss to run this. All the same, good answer, should be the accepted answer. Note that on different models (hardware related? not sure) there is a range of Ctrl-Alt-FKeys that will open a text-based login, some I have seen, this only works on F4-F7. Off the top of my head (booted into Windows now, heresy, I know) I think it's Ctrl-Alt-F3 that gets you back to the graphical login?
    – JimLohse
    Feb 17 '16 at 12:32
  • @JimLohse In Xubuntu, it is Ctrl+Alt+F7, if I'm not wrong. Now I'm Fedora, which is a different command, as you said Jul 25 '16 at 3:17
  • This worked for me but it restarted the session except for few windows. Is that expected?
    – Shashwat
    May 31 '20 at 10:33
2

Easier way: Switch to different session using Ctrl+Alt+F1 (or F2-F6) and then back to your session using Ctrl+Alt+F7

1
  • 1
    This did not work for me. On a Lenovo Thinkpad X1 Carbon
    – spicy.dll
    Apr 22 '20 at 19:54
1

I was able to work around the problem by going into settings, opening "Light Locker Settings" and setting "Enable light-locker" to off.

Learn more about light locker at http://xubuntu.org/news/screen-locking-in-xubuntu-14-04/

1
  • Click on Light Locker Setting does not work for me. No action after click. No program appears. I see dim light on wake-up and there Xubuntu stops. Sep 25 '17 at 13:38
0

My Lenovo E531 does the same. I insert the password and the screen goes black. Then I press the power button, I enter the password (again!) and everything it's fine. I know it's not the answer you needed, it's just a workaround than works for me. I hope it will help you too.

0

Had the same problem too. My solution was on Light Locker Settings too but I didn't disable light locker. I just enabled "Lock on suspend" and the problem solved.

0

The answer from WolfangAukang helped me. But in my case, it was sddm which had to be restarted.

Get into the command line using Ctrl+Alt+F1.

Put your credentials user/password.

Write the following:

sudo service sddm restart

So it will take you back to the login screen.

0

Seems to be a bug in light-locker on most laptops. A workaround is, using suspend instead of xflock4. This can be achieved changing the next three options in XFCE4:

  • Whiskers menu > right click > settings > commands > lock screen -> and write 'systemctl suspend' instead of 'xflock4'
  • Settings panel > power manager > security > lock session automatically > never
  • Settings panel > session and start > advanced > lock screen before suspend > unchecked

An easier workaround is just installing xscreensaver. It's ugly, but it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.