I am relatively new to ubuntu. i am using idea intellij from jetbrains for developing applications with gwt and java. Recently i have installed ubuntu 14.04 and everything works fine but idea 13. I have jdki586-1.7 and i have installed it using this tutorial. Then i have extracted intellij to my home directory and tried to launch idea.sh from terminal with:


from path/to/idea/bin directory. But, it gave me this error:

./idea.sh: 1: eval: /usr/local/java/jdk1.7.0_51/bin/java: not found

I have searched through the Internet, but couldn't find similar topic. Any suggestion would be appreciated. Thanks in advance for your answer.


I had a same issue but the above answer did not solve my issue. I had to switch as a root user then running idea.sh worked fine without any issue. May be a permission issue or setting $PATH may be the issue.


Obviously you did not setup java correctly. Using the webupd8 ppa is the easiest way to install java on ubuntu. Just type these lines in terminal:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer

then verify that your java is ready

java -version
  • Thanks for your answer, but i have tried this and it asked me to check correctness of the command sudo add-apt-repository ppa:webupd8team/java. i have reinstalled ca-certificates and it didn't help as well: still incorrect installed jdk and i cannot launch idea intelliJ – JIT Develop May 8 '14 at 4:43
  • Thanks, I have figured it out. The thing i have to do was to export proxies and then use sudo -E instead of sudo alone before add-apt-repository ppa:webupd8team/java. it worked with sudo -E .... – JIT Develop May 8 '14 at 5:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.