This question already has an answer here:

I installed Ubuntu 14.04 (dual boot with Win 7) and it was working fine. But suddenly one fine day I can't login to my user account, when I log it just flashes and then it goes back to the login screen. But the odd thing is that I can log with the guest account.

I have 2 accounts one owner account/user account and another one created for the installation of Oracle. Only the guest account can login.

From the login screen, I have pressed Ctrl+Alt+F1 to get to a prompt, and login but the same thing happened there too, I entered the correct username and credentials but it flashed and goes back to the login screen.

marked as duplicate by karel, Eric Carvalho, Fabby, Sparhawk, mikewhatever Feb 14 '15 at 17:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Try to recreate the root account from the kernel level which you can do prior to booting into – Ashvin Ashok Kumar May 7 '14 at 12:35
  • This seems to be similar to askubuntu.com/q/223501/103256. Maybe duplicate? – Sina May 8 '14 at 14:41
  • I have gone through the suggestions posted in the thread , but in my case I am not able to log in the console with the user-id/password after I press Ctrl+Alt+F1/F2/F3... Not sure how I can re-create the root account from kernel level if I can't login. Please suggest. – Abhishek May 18 '14 at 6:54
  • 1
    Is this question still unanswered? – user271219 Oct 1 '14 at 1:48

This happened to me a couple of times too, this is probably because there is little space on your machine or an issue with LightDM or Xauthority but most probably xauthority. Here is what I did;

I simultaneously pressed Ctrl+Alt+F1, Login with your user name and password, and enter following command:

sudo mv .Xauthority .XauthorityBak


sudo reboot

After that try again.

  • 2
    A reboot is probably not needed. – Smile4ever Oct 31 '14 at 18:16
  • is the name .XauthorityBak a standard one with particular meaning or just a random one? Also, can you just delete it with rm .Xauthority ? – Earendil Dec 1 '14 at 17:49
  • 2
    I had the same problem, it happened after a reboot after some system updates. I did sudo rm /home/<username>/.Xauthority* sudo apt-get install --reinstall xorg sudo reboot. This worked for me. – Christine Dec 14 '14 at 15:17
  • Awesome this worked for me. – Naman Apr 11 '15 at 19:20
  • Worked for me after a misconfiguration of bspwm, thank you – root Feb 15 '16 at 13:26

I was having the same problem. I was installing some software to do go development, but I didn't do anything (that I know of) that would have modified permissions of the home directory (the problem previously reported).

I typed the Ctl-Alt-F1 and got the terminal login. I tried fixing the permissions on the home directory, but that didn't fix anything.

Then I recalled adding a path command to the .profile

I removed all my changes to the .profile, and now I am fixed.

  • I recall modifying the .profile file when I was trying to install Oracle. I didn't had any other way to correct the issue so had to re-install the Linux all over again. :( – Abhishek May 29 '14 at 19:40

Same issue happened to me. I was able to login as myself after Ctrl+Alt+F1. .xsession-errors pointed to an error in my .bashrc. After I removed the offending line from my .bashrc, I was able to login through the graphical environment.

Not the answer you're looking for? Browse other questions tagged or ask your own question.