8

I have Ubuntu 14.04 and Gnome 3.12 (using a dark theme) and in some applications I have now a big, white title bar.

How can I remove title bar of an application? In gnome 3.10 I used gnome-shell-extension pixel saver but now this extensions is outdated.

enter image description here

  • If you want to remove title bars for maximized windows, you can use the second method . However, it will not be removed for windows with Client Side Decorations. – X4lldux Jun 19 '14 at 15:09
4

I solved this by using Maximus.

For newer versions of gnome (> 3.8) you may need to edit metadata.json to match this pull request and manually install the extension. Instructions lifted from maximus homepage with a few edits:

hg clone ssh://hg@bitbucket.org/mathematicalcoffee/maximus-gnome-shell-extension
hg up gnome3.4 # or `stable` if on GNOME 3.2
cd maximus-gnome-shell-extension
# NOW OPEN AND EDIT THE OUTDATED metadata.json FILE. See link above.
make # <-- VERY IMPORTANT
cp -r maximus@mathematical.coffee.gmail.com ~/.local/share/gnome-shell/extensions
# enable maximus if you haven't already:
gnome-shell-extension-tool -e maximus@mathematical.coffee.gmail.com
Restart gnome-shell.
  • 1
    There also is this extension, which apparently will work with 3.12. – Wilf Oct 1 '14 at 11:41
3

Welcome to the wonderful world of Gnome 3.12's forced client side decorations. CSD are hardcoded in GTK 3.12, the only way to get rid of them is to downgrade GTK to V 3.10.

  • Hmmm... well I have some themes installed that at least re-color the title bar, but I can't seem to get that code working in Adwaita or Adwaita-borderless to be more precise. Any Ideas? I just want to make the title bar solid black. – Costa May 28 '14 at 4:12
  • Actually, I'm running 3.10 I think: ii libgtk-3-0:amd64 3.10.8-0ubuntu1 amd64 GTK+ graphical user interface library ii libgtk2.0-0:amd64 2.24.23-0ubuntu1 amd64 GTK+ graphical user interface library – Costa Jun 4 '14 at 4:59
2

Gnome Shell Extension Pixel Saver just works.

https://github.com/deadalnix/pixel-saver

1

You have to use the Tweak Tool and change the Window Theme from there.

1

Like alb3rtano0012 suggested, you should download Tweak Tool aka. 'Advanced Settings' [Tweak advanced GNOME 3 settings], that enables you to choose a different window theme, matching your overall dark GTK+theme.

Since it is not included yet in the 14.04 repos you can install it like this:

  1. Open a terminal window.
  2. Type in the following command then hit Enter.

sudo apt-get install unity-tweak-tool gnome-tweak-tool

Source: Install tweak tools in Ubuntu 14.04 | Guide 01

enter image description here

GNOME Tweak Tool allows the adjustment of several advanced GNOME options that can't be configured in gnome-control-center. This includes things like:

  • fonts used in user interface elements and titlebar
  • font hinting and aliasing
  • alternative user interface themes
  • changes in window management behaviour
  • behaviour on laptop lid close
  • file manager desktop icons
  • icons in menus and buttons
  • 1
    I don't think changing the window theme would work. I haven't installed custom themes but it doesn't work with the default ones that come pre-installed. Can you provide a working example for how to actually make it work. – Aditya May 9 '14 at 9:07
  • How to you apply/change the default themes and what exactly doesn't work? Some more information would be helpful. You can always edit your question and add more information. Also have you already tried my suggestion in the answer and that didn't work as well?! – v2r May 10 '14 at 16:20
  • 1
    Did it actually work for you? You haven't provided a screenshot showing where the Title bar is hidden. Your answer is not an answer, just a guidance which might work in your belief. BTW, I am not the OP of the question. – Aditya May 10 '14 at 17:08
  • 1
    Tweak Tool only changes gtk3 settings, but some apps, e.g. Firefox, Sublime Text 3, run on gtk2. Options exist, though I'm still searching for something that works for 3.12. For some info, see askubuntu.com/questions/337018/… , plus.google.com/+RoiMMrNucky/posts/KsybAs8Htgc , bbs.archlinux.org/viewtopic.php?id=151846 – Rasmus Jun 22 '14 at 12:40
  • Changing your window theme as suggested in Tweak Tool will work although it will appear not to work until you restart GNOME. Alt+F2 to open the run prompt then type just "r" and press enter. This will restart GNOME and thus activate the CSD of that theme. Numix is a great example of this working. – Michael Tunnell Jul 21 '14 at 2:24
1

If you read this tutorial from WebUpd8 you will be able to manually make these changes. - http://www.webupd8.org/2011/05/how-to-remove-maximized-windows.html

Follow the steps for Method #2.

Note- Method #1 is no longer maintained so it is not relevant anymore but Method #2 does still work.

This is if you want to remove the titlebar completely, if you want to blend the titlebar with the theme then @v2r's solution is more applicable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.