I removed the HDD from a Toshiba Computer I bought today and installed a 250GB SSD. After installing it, I immediately installed Ubuntu 14.04 on it from a USB drive. Everything went fine during installation, but when I restarted I got the message "Reboot and select proper Boot device or Insert Boot Media in selected Boot Device and press a key". That message came up after a nano second screen that says "Checking Media Presence" and then "No Media Present".

When I reboot using the USB stick, I can see the SSD drive and it has the OS written on it and it looks like it's been partitioned correctly.

Can someone please tell me what I need to do to get my computer to boot up? I read something about how the Secure boot and CSM or UEFI might be a factor, but I'm not experienced enough with new Bios to know how to configure those settings. I also read about Grub probably not installing on the SSD and I might just have to fix Grub for it to work, but I haven't been able to do that through the Ubuntu running of the USB stick. Any help or links to good threads would be very helpful. If you have any questions, I would be very happy to help you in helping me.


  • The installer will work with secure boot on. But did you install with secure boot in UEFI mode, UEFI mode, or BIOS boot mode. How you boot installer is how it installs. You can copy the link Boot-Repair gives you and post it in your first post. Then we can see exactly how you installed. Review this, but if not dual booting you can skip all the Windows issues. help.ubuntu.com/community/UEFI
    – oldfred
    May 7, 2014 at 3:50
  • Can you get into the hardware system settings (a.k.a. BIOS)? May 7, 2014 at 4:22
  • I can. I am currently re-installing 14.04 in legacy mode like a link that was on the page 'oldfred' suggested. I'll update on the install as soon as it finishes. May 7, 2014 at 4:26
  • YES!!! It installed and booted up in CSM (legacy) mode. Thanks oldfred for the link! I would have liked it up install and work out of the box in UEFI, but I'll take it. Maybe I'll change it up when I add Win7 in the future. Thanks to all that helped! May 7, 2014 at 4:34
  • 1
    Possible duplicate of Recovering GRUB after installing Windows 7?
    – mchid
    Jul 10, 2016 at 2:53

2 Answers 2


I'm not familiar with laptop BIOS things but I've ever tried grub-fix and use it as a way of installing my own live system.

Though I've never tried to fix grub in 14.04 but it should be OK. So would you please tell where you get stuck while fixing grub?

Also,the following link may help.




  • I tried boot repair and it said there was an error and I have the url it gave me, but I don't really know what to do that that page of data. I have been using that last link you posted, and I get stuck at " grub-install /dev/sda". When I type that in I get "Installing for x86_64-efi platform. grub-install: error: cannot find EFI directory." May 7, 2014 at 3:17

I installed 14.04 on a laptop with UEFI and it's not quite as straightforward as with a conventional BIOS.

I suggest you go into the BIOS (usually by tapping F2 repeatedly on bootup) and ensure that F12 is not disabled. Having it enabled will allow for a "one time" boot.

Try rebooting the machine and hold down F12 as soon as you power up. My boot menu doesn't come up on a conventional boot. I have to use F12 to get to it.

  • Thanks for the suggestion. Unfortunately it didn't work. I can get the drive to be recognized, but somehow it doesn't load Ubuntu. Thanks anyway. May 7, 2014 at 3:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.