4

My gnome terminal has stopped showing the menu bars when I mouse over the top bar. I'm not sure why this is happening. I did a full update (apt-get update; apt-get dist-upgrade) and then rebooted, but that didn't do anything. I even tried changing my shell to see if something in my profile was causing this behavior, but that didn't work either. Is this a bug, or do I have something set wrong?

Another error that showed up around the same time is that when in tmux pressing Ctrl+P causes ^P to be written to the terminal. Could these two errors be related? After resetting my gnome-terminal settings this problem still exists, so it is unrelated.

3

I found that deleting (or moving in my case) the gnome terminal config located at ~/.gconf/apps/gnome-terminal/profiles/Default/%gconf.xml and rebooting causes the menu to reappear. I've posted my config here for anyone who's interested (the commented line 6 was the cause of the problem).

I'm unsure how I got the setting on line 6 set. Looking at the settings dialog for gnome terminal, there's nothing that I see that seems like it would cause that behavior.

Edit

Found the setting. I'm not sure how I missed before, or why I clicked it in the first place. I don't know how this "feature" could ever be a good thing to have, since you can't get back into the settings to set it back.

enter image description here

2
  • 1
    By the way, right-clicking on the terminal window shows a popup menu. One of the menu items is a "Show Menubar" toggle. So you can get the menubar back and get to the preferences dialog. – Michael Miller May 7 '14 at 0:47
  • I had the same issue after running a setup script that created a %gconf.xml file on a clean install of 15.10. The highlighted setting does not show up in the preferences in 15.10. I deleted the %gconf.xml file and on reboot menu was operating as expected. – Antonios Hadjigeorgalis Dec 16 '15 at 15:07
0

You can also turn on the menu bar with this command in terminal:

gnome-terminal --show-menubar

It helped me to solve this problem, so I'm posting it here. I hope it will be useful for others.

1
  • Didn't work for me – Nav Jul 19 '17 at 14:49
0

In my case (Ubuntu 16), going to System Settings > Appearance > Behaviour. Under the "Show the menus for a window", selecting "In the windows title bar", solved it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.