5

I am using Ubuntu 14.04 and I have been experiencing the following issue with former releases as well.

I am using a German keyboard layout. However, I am missing the key to display the pipe- / inequality-signs (which on German keyboards is supposed to be left to the Y key).

I already tried to add or remove different German keyboard layouts using system settings but non of the layouts include this key. The best I could get so far is to have access to t he following symbols: » and «. However, these are not the appropriate German inequality signs plus the pipe symbol is missing.

See this screenshot of my German keyboard layout:

enter image description here

4
  • In the picture you show, it looks like the < and > are available with shift+alt gr. The lack of a pipe sounds like a bad flaw in the design. Have you looked at other German language keyboards (eg Swiss German or Austria) to see if any of them are in fact a better match?
    – Jon Hanna
    May 6 '14 at 12:31
  • Indeed, shift+alt gr leads to the following symbols: and . Again, they seem to be not the correct inequation symbols. The correct ones should be way larger. Also alternative German language keyboards are missing the symbols. May 6 '14 at 12:50
  • 1
    Yeah, that's a single quotation mark. Certainly useful for some styles of writing German, but it's hard to get by without >, < and |.
    – Jon Hanna
    May 6 '14 at 13:07
  • You can try to modify the keyboard layout as I did for my Spanish keyboard. rlog.rgtti.com/2014/05/01/… (PS: wow, a keyboard layout that seems as bad as the Italian one!)
    – Rmano
    May 6 '14 at 14:27
5

It might be, that the wrong keyboard model is selected. To view currently installed keyboard model issue:

setxkbmap -print | grep geometry

If you see pc104 there you will have a 104 key layout where the > < | key is not defined.

In order to use a typical German 105 keys keyboard, you have to choose the "pc105" type, labeled "Generische PC-Tastatur mit 105 Tasten (Intl)" in the German localization of Ubuntu on installation. To change this later you can issue

sudo dpkg-reconfigure keyboard-configuration

or edit /etc/default/keyboard as root. My file looks as following:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT="nodeadkeys"
XKBOPTIONS=""

BACKSPACE="guess"

On Xfce you can change the setting for your user only as well. The respective option is in Settings/Keyboard Settings/Layout. Nevertheless, since I don't use Unity or Gnome, I have no idea where the respective setting is hidden there (if someone knows: please update this answer).

2
  • It appears the keyboard mode setting can not be changed from Unity GUI (at least I have not found it).
    – Takkat
    May 6 '14 at 18:09
  • 1
    Simple and plain. The dpkg-reconfigure keyboard-configuration command was the solution. May 7 '14 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.